# CVE-2022-21647: Deserialization of Untrusted Data in Codeigniter4

> Remote attackers can inject arbitrary objects via the old() function to execute PHP code or perform SQL injection in CodeIgniter4.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-codeigniter-2022-21647, GHSA-w6jr-wj64-mc9x

## What is CVE-2022-21647?

CVE-2022-21647 is a high-severity unsafe deserialization vulnerability in CodeIgniter4, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-21647?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.1.6 |
| `codeigniter4/framework` | Packagist | All versions | 4.1.6 |
| `codeigniter` | Bitnami | From 4.0.0 | 4.1.6 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2022-21647?

Upgrade codeigniter4/framework to 4.1.6 or later.

## Is CVE-2022-21647 being exploited?

There is no known exploitation of CVE-2022-21647 in the wild and no public exploit code.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21647 and fix it if it is affected.

What it is: CVE-2022-21647 is a high-severity unsafe deserialization vulnerability in CodeIgniter4, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21647 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.6
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.6
- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21647/ (Markdown: https://insights.sbomify.com/CVE-2022-21647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21647
- OSV: https://osv.dev/vulnerability/CVE-2022-21647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21647/
Summaries are generated and may contain mistakes; the official description above is the record.
