# CVE-2022-21652: Insufficient Session Expiration in shopware


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-p523-jrph-qjc6

## What is CVE-2022-21652?

CVE-2022-21652 is a low-severity vulnerability in Shopware Shopware, published on 5 Jan 2022. 

### Official description

Shopware is an open source e-commerce software platform. In affected versions shopware would not invalidate a user session in the event of a password change. With version 5.7.7 the session validation was adjusted, so that sessions created prior to the latest password change of a customer account can't be used to login with said account. This also means, that upon a password change, all existing sessions for a given customer account are automatically considered invalid. There is no workaround for this issue.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-21652?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | From 5.7.3 | 5.7.7 |
| `shopware/shopware` | Packagist | From 5.7.3 | 5.7.7 |

Products: Shopware Shopware.

## How do I fix CVE-2022-21652?

Upgrade shopware/shopware to 5.7.7 or later.

## Is CVE-2022-21652 being exploited?

There is no known exploitation of CVE-2022-21652 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21652 and fix it if it is affected.

What it is: CVE-2022-21652 is a low-severity vulnerability in Shopware Shopware, published on 5 Jan 2022. 
Exploitation: There is no known exploitation of CVE-2022-21652 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected from 5.7.3; fixed in 5.7.7
- shopware/shopware (Packagist): affected from 5.7.3; fixed in 5.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21652/ (Markdown: https://insights.sbomify.com/CVE-2022-21652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21652
- OSV: https://osv.dev/vulnerability/CVE-2022-21652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21652/
Summaries are generated and may contain mistakes; the official description above is the record.
