# CVE-2022-2166: Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon

> Attackers can bypass authentication attempt restrictions to brute-force user accounts in Mastodon social network instances.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2022
- **Updated:** 29 Apr 2025
- **Also known as:** BIT-mastodon-2022-2166, GHSA-q5qv-4wvf-4v9h

## What is CVE-2022-2166?

CVE-2022-2166 is a critical vulnerability in mastodon/mastodon, published on 16 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Restriction of Excessive Authentication Attempts in GitHub repository mastodon/mastodon prior to 4.0.0.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2022-2166?

1 open source package ship an affected version, including mastodon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | All versions | 3.5.6 |

Products: Joinmastodon Mastodon.

## How do I fix CVE-2022-2166?

Upgrade mastodon to 3.5.6 or later.

## Is CVE-2022-2166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2166 exists.

## Other vulnerabilities in mastodon/mastodon

- [CVE-2023-36460](https://insights.sbomify.com/CVE-2023-36460/): Mastodon vulnerable to arbitrary file creation through media attachments (critical 10.0)
- [CVE-2022-24307](https://insights.sbomify.com/CVE-2022-24307/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-21018](https://insights.sbomify.com/CVE-2018-21018/): Auth bypass in n/a (critical 9.8)
- [CVE-2024-23832](https://insights.sbomify.com/CVE-2024-23832/): Mastodon Remote user impersonation and takeover (critical 9.4)
- [CVE-2023-36459](https://insights.sbomify.com/CVE-2023-36459/): Mastodon vulnerable to Cross-site Scripting through oEmbed preview cards (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2166 and fix it if it is affected.

What it is: CVE-2022-2166 is a critical vulnerability in mastodon/mastodon, published on 16 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2166 exists.

Affected packages and fixed versions:
- mastodon (Bitnami): affected all versions; fixed in 3.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2166/ (Markdown: https://insights.sbomify.com/CVE-2022-2166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2166
- OSV: https://osv.dev/vulnerability/CVE-2022-2166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2166/
Summaries are generated and may contain mistakes; the official description above is the record.
