{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-21662 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.8.3 or later.","what":"CVE-2022-21662 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 6 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-21662 and fix it if it is affected.\n\nWhat it is: CVE-2022-21662 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 6 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-21662 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 5.8.3\n- wordpress-multisite (Bitnami): affected all versions; fixed in 5.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21662/ (Markdown: https://insights.sbomify.com/CVE-2022-21662/index.md)","id":"CVE-2022-21662","markdown":"https://insights.sbomify.com/CVE-2022-21662/index.md","name":"CVE-2022-21662","record":{"aliases":["BIT-wordpress-2022-21662","BIT-wordpress-multisite-2022-21662","DEBIAN-CVE-2022-21662","GHSA-699q-3hj9-889w","UBUNTU-CVE-2022-21662"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress CMS","requires_auth":"low_privilege","summary":"Low-privileged users can inject JavaScript to execute code or escalate privileges against high-privileged users in WordPress.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Low-privileged authenticated users (like author) in WordPress core are able to execute JavaScript/perform stored XSS attack, which can affect high-privileged users. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS in WordPress","id":"CVE-2022-21662","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","wordpress:wordpress"],"type":"xss","year":"2022"},"n_packages":2,"n_references":6,"next":{"headline":"Authenticated Object Injection in Multisites in WordPress","id":"CVE-2022-21663"},"packages":[{"ecosystem":"Bitnami","fixed":["5.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2022-21662"},{"ecosystem":"Bitnami","fixed":["5.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2022-21662"}],"prev":{"headline":"SQL injection in WordPress","id":"CVE-2022-21661"},"products":["wordpress-develop"],"published":"2022-01-06","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["WordPress"]},"summary":"Low-privileged users can inject JavaScript to execute code or escalate privileges against high-privileged users in WordPress.","url":"https://insights.sbomify.com/CVE-2022-21662/"}