{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21663 exists.","fix":"Upgrade wordpress to 5.8.3 or later.","what":"CVE-2022-21663 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21663 and fix it if it is affected.\n\nWhat it is: CVE-2022-21663 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21663 exists.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 5.8.3\n- wordpress-multisite (Bitnami): affected all versions; fixed in 5.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21663/ (Markdown: https://insights.sbomify.com/CVE-2022-21663/index.md)","id":"CVE-2022-21663","markdown":"https://insights.sbomify.com/CVE-2022-21663/index.md","name":"CVE-2022-21663","record":{"aliases":["BIT-wordpress-2022-21663","BIT-wordpress-multisite-2022-21663","DEBIAN-CVE-2022-21663","GHSA-jmmq-m8p8-332h","UBUNTU-CVE-2022-21663"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress CMS","requires_auth":"high_privilege","summary":"Super Admins in WordPress multisite environments can exploit object injection to bypass hardening, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. On a multisite, users with Super Admin role can bypass explicit/additional hardening under certain conditions through object injection. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Authenticated Object Injection in Multisites in WordPress","id":"CVE-2022-21663","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","wordpress:wordpress"],"type":"deserialization","year":"2022"},"n_packages":2,"n_references":7,"next":{"headline":"SQL injection in WordPress","id":"CVE-2022-21664"},"packages":[{"ecosystem":"Bitnami","fixed":["5.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2022-21663"},{"ecosystem":"Bitnami","fixed":["5.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2022-21663"}],"prev":{"headline":"Stored XSS in WordPress","id":"CVE-2022-21662"},"products":["wordpress-develop"],"published":"2022-01-06","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["WordPress"]},"summary":"Super Admins in WordPress multisite environments can exploit object injection to bypass hardening, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2022-21663/"}