# CVE-2022-21663: Authenticated Object Injection in Multisites in WordPress

> Super Admins in WordPress multisite environments can exploit object injection to bypass hardening, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-wordpress-2022-21663, BIT-wordpress-multisite-2022-21663, DEBIAN-CVE-2022-21663, GHSA-jmmq-m8p8-332h, UBUNTU-CVE-2022-21663

## What is CVE-2022-21663?

CVE-2022-21663 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. On a multisite, users with Super Admin role can bypass explicit/additional hardening under certain conditions through object injection. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-21663?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 5.8.3 |
| `wordpress-multisite` | Bitnami | All versions | 5.8.3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Wordpress Wordpress.

## How do I fix CVE-2022-21663?

Upgrade wordpress to 5.8.3 or later.

## Is CVE-2022-21663 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21663 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21663 and fix it if it is affected.

What it is: CVE-2022-21663 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21663 exists.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 5.8.3
- wordpress-multisite (Bitnami): affected all versions; fixed in 5.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21663/ (Markdown: https://insights.sbomify.com/CVE-2022-21663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21663
- OSV: https://osv.dev/vulnerability/CVE-2022-21663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21663/
Summaries are generated and may contain mistakes; the official description above is the record.
