# CVE-2022-21667: Denial of Service in soketi

> An unhandled case when reading POST requests with empty bodies causes the soketi WebSockets server to crash, allowing unauthenticated attackers to cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-86ch-6w7v-v6xf

## What is CVE-2022-21667?

CVE-2022-21667 is a high-severity denial of service vulnerability in soketi, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

soketi is an open-source WebSockets server. There is an unhandled case when reading POST requests which results in the server crashing if it could not read the body of a request. In the event that a POST request is sent to any endpoint of the server with an empty body, even unauthenticated with the Pusher Protocol, it will crash the server. All users that run the server are affected by this vulnerability and it's highly recommended to upgrade to the latest patch. There are no workarounds for this issue.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2022-21667?

2 open source packages ship an affected version, including @soketi/soketi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@soketi/soketi` | npm | All versions | 0.24.1 |
| `@soketi/soketi` | npm | All versions | 0.24.1 |

Products: Soketi Project Soketi.

## How do I fix CVE-2022-21667?

Upgrade @soketi/soketi to 0.24.1 or later.

## Is CVE-2022-21667 being exploited?

There is no known exploitation of CVE-2022-21667 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21667 and fix it if it is affected.

What it is: CVE-2022-21667 is a high-severity denial of service vulnerability in soketi, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21667 in the wild and no public exploit code.

Affected packages and fixed versions:
- @soketi/soketi (npm): affected all versions; fixed in 0.24.1
- @soketi/soketi (npm): affected all versions; fixed in 0.24.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21667/ (Markdown: https://insights.sbomify.com/CVE-2022-21667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21667
- OSV: https://osv.dev/vulnerability/CVE-2022-21667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21667/
Summaries are generated and may contain mistakes; the official description above is the record.
