# CVE-2022-21668: Pipenv's requirements.txt parsing allows malicious index url in comments

> Attackers can inject malicious index URLs in requirements.txt comments, causing pipenv to install malicious packages and execute arbitrary code.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qc9x-gjcv-465w, PYSEC-2022-6, ROOT-APP-PYPI-CVE-2022-21668, UBUNTU-CVE-2022-21668

## What is CVE-2022-21668?

CVE-2022-21668 is a high-severity vulnerability in Fedoraproject Fedora, published on 10 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

pipenv is a Python development workflow tool. Starting with version 2018.10.9 and prior to version 2022.1.8, a flaw in pipenv's parsing of requirements files allows an attacker to insert a specially crafted string inside a comment anywhere within a requirements.txt file, which will cause victims who use pipenv to install the requirements file to download dependencies from a package index server controlled by the attacker. By embedding malicious code in packages served from their malicious index server, the attacker can trigger arbitrary remote code execution (RCE) on the victims' systems. If an attacker is able to hide a malicious `--index-url` option in a requirements file that a victim installs with pipenv, the attacker can embed arbitrary malicious code in packages served from their malicious index server that will be executed on the victim's host during installation (remote code execution/RCE). When pip installs from a source distribution, any code in the setup.py is executed by the install process. This issue is patched in version 2022.1.8. The GitHub Security Advisory contains more information about this vulnerability.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-1284 (Improper Validation of Specified Quantity in Input), CWE-791 (Incomplete Filtering of Special Elements), CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-427 (Uncontrolled Search Path Element), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-21668?

3 open source packages ship an affected version, including pipenv. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pipenv` | PyPI | From 2018.10.9 | 2022.1.8 |
| `pipenv` | PyPI | From 2018.10.9 | 2022.1.8 |
| `pipenv` | PyPI | From 2018.10.9 | 2022.1.8 |

Products: Fedoraproject Fedora, Pypa Pipenv.

## How do I fix CVE-2022-21668?

Upgrade pipenv to 2022.1.8 or later.

## Is CVE-2022-21668 being exploited?

There is no known exploitation of CVE-2022-21668 in the wild and no public exploit code.

Public exploit code:

- https://github.com/sreeram281997/CVE-2022-21668-Pipenv-RCE-vulnerability (github_poc): https://github.com/sreeram281997/CVE-2022-21668-Pipenv-RCE-vulnerability

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21668 and fix it if it is affected.

What it is: CVE-2022-21668 is a high-severity vulnerability in Fedoraproject Fedora, published on 10 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-21668 in the wild and no public exploit code.

Affected packages and fixed versions:
- pipenv (PyPI): affected from 2018.10.9; fixed in 2022.1.8
- pipenv (PyPI): affected from 2018.10.9; fixed in 2022.1.8
- pipenv (PyPI): affected from 2018.10.9; fixed in 2022.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21668/ (Markdown: https://insights.sbomify.com/CVE-2022-21668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21668
- OSV: https://osv.dev/vulnerability/CVE-2022-21668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21668/
Summaries are generated and may contain mistakes; the official description above is the record.
