# CVE-2022-21670: Uncontrolled Resource Consumption in markdown-it

> An attacker can cause significant performance degradation in markdown-it by submitting specially crafted long inputs, leading to denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2022
- **Updated:** 22 Apr 2025
- **Also known as:** CLSA-2026-1773015255, CLSA-2026-1773620215, CLSA-2026-1789374715, CLSA-2026-1792369290, DEBIAN-CVE-2022-21670, GHSA-6vfc-qv3f-vr6c, ROOT-APP-NPM-CVE-2022-21670, UBUNTU-CVE-2022-21670

## What is CVE-2022-21670?

CVE-2022-21670 is a medium-severity denial of service vulnerability in markdown-it, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

markdown-it is a Markdown parser. Prior to version 1.3.2, special patterns with length greater than 50 thousand characterss could slow down the parser significantly. Users should upgrade to version 12.3.2 to receive a patch. There are no known workarounds aside from upgrading.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-21670?

2 open source packages ship an affected version, including markdown-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown-it` | npm | All versions | 12.3.2 |
| `markdown-it` | npm | All versions | 12.3.2 |

Products: Markdown-It Project Markdown-It.

## How do I fix CVE-2022-21670?

Upgrade markdown-it to 12.3.2 or later.

## Is CVE-2022-21670 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21670 exists.

## Other vulnerabilities in markdown-it

- [CVE-2026-2327](https://insights.sbomify.com/CVE-2026-2327/): markdown-it is has a Regular Expression Denial of Service (ReDoS) (medium 6.9)
- [CVE-2025-7969](https://insights.sbomify.com/CVE-2025-7969/): Markdown-it 14.1.0 - Cross-site scripting (XSS) (medium 6.9)
- [CVE-2026-48988](https://insights.sbomify.com/CVE-2026-48988/): markdown-it: Quadratic complexity DoS in smartquotes rule via replaceAt string operations (medium 5.3)
- [CVE-2015-3295](https://insights.sbomify.com/CVE-2015-3295/): Cross-site scripting in n/a (medium 5.3)
- [CVE-2015-10005](https://insights.sbomify.com/CVE-2015-10005/): markdown-it html_re.js redos (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21670 and fix it if it is affected.

What it is: CVE-2022-21670 is a medium-severity denial of service vulnerability in markdown-it, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21670 exists.

Affected packages and fixed versions:
- markdown-it (npm): affected all versions; fixed in 12.3.2
- markdown-it (npm): affected all versions; fixed in 12.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21670/ (Markdown: https://insights.sbomify.com/CVE-2022-21670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21670
- OSV: https://osv.dev/vulnerability/CVE-2022-21670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21670/
Summaries are generated and may contain mistakes; the official description above is the record.
