{"answers":{"affected":"2 open source packages ship an affected version, including @replit/crosis. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21671 in the wild and no public exploit code.","fix":"Upgrade @replit/crosis to 7.3.1 or later.","what":"CVE-2022-21671 is a high-severity vulnerability in replit crosis, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21671 and fix it if it is affected.\n\nWhat it is: CVE-2022-21671 is a high-severity vulnerability in replit crosis, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @replit/crosis (npm): affected all versions; fixed in 7.3.1\n- @replit/crosis (npm): affected all versions; fixed in 7.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21671/ (Markdown: https://insights.sbomify.com/CVE-2022-21671/index.md)","id":"CVE-2022-21671","markdown":"https://insights.sbomify.com/CVE-2022-21671/index.md","name":"CVE-2022-21671","record":{"aliases":["GHSA-7w54-gp8x-f33m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Replit client library","requires_auth":"low_privilege","summary":"An attacker can intercept Replit tokens via a misconfigured fallback proxy URL, leading to full compromise of the associated Repl.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"crosis","vendor":"replit"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"@replit/crosis is a JavaScript client that speaks Replit's container protocol. A vulnerability that involves exposure of sensitive information exists in versions prior to 7.3.1. When using this library as a way to programmatically communicate with Replit in a standalone fashion, if there are multiple failed attempts to contact Replit through a WebSocket, the library will attempt to communicate using a fallback poll-based proxy. The URL of the proxy has changed, so any communication done to the previous URL could potentially reach a server that is outside of Replit's control and the token used to connect to the Repl could be obtained by an attacker, leading to full compromise of that Repl (not of the account). This was patched in version 7.3.1 by updating the address of the fallback WebSocket polling proxy to the new one. As a workaround, a user may specify the new address for the polling host (`gp-v2.replit.com`) in the `ConnectArgs`. More information about this workaround is available in the GitHub Security Advisory.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential exposure of Replit tokens to an Unauthorized Actor in @replit/crosis","id":"CVE-2022-21671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"/etc/pki/tls and /etc/ssl/certs include distrusted certificates in make-ca","id":"CVE-2022-21672"},"packages":[{"ecosystem":"npm","fixed":["7.3.1"],"introduced":["0"],"last_affected":[],"package":"@replit/crosis","purl":null,"source":"GHSA-7w54-gp8x-f33m"},{"ecosystem":"npm","fixed":["7.3.1"],"introduced":["0"],"last_affected":[],"package":"@replit/crosis","purl":"pkg:npm/%40replit/crosis","source":"GHSA-7w54-gp8x-f33m"}],"prev":{"headline":"Uncontrolled Resource Consumption in markdown-it","id":"CVE-2022-21670"},"products":["crosis"],"published":"2022-01-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["replit"]},"summary":"An attacker can intercept Replit tokens via a misconfigured fallback proxy URL, leading to full compromise of the associated Repl.","url":"https://insights.sbomify.com/CVE-2022-21671/"}