{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21672 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-21672 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-21672 is a medium-severity vulnerability in lfs-book make-ca, published on 10 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21672 and fix it if it is affected.\n\nWhat it is: CVE-2022-21672 is a medium-severity vulnerability in lfs-book make-ca, published on 10 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21672 in the wild and no public exploit code.\n\nAffected product: lfs-book make-ca. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21672/ (Markdown: https://insights.sbomify.com/CVE-2022-21672/index.md)","id":"CVE-2022-21672","markdown":"https://insights.sbomify.com/CVE-2022-21672/index.md","name":"CVE-2022-21672","record":{"aliases":["GHSA-m5qh-728v-4xrx"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PKI configuration utility","requires_auth":"low_privilege","summary":"make-ca incorrectly trusts explicitly untrusted certificates, enabling man-in-the-middle attacks against systems using affected versions.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"make-ca","vendor":"linuxfromscratch"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-115","name":"Misinterpretation of Input"}],"description":"make-ca is a utility to deliver and manage a complete PKI configuration for workstations and servers. Starting with version 0.9 and prior to version 1.10, make-ca misinterprets Mozilla certdata.txt and treats explicitly untrusted certificates like trusted ones, causing those explicitly untrusted certificates trusted by the system. The explicitly untrusted certificates were used by some CAs already hacked. Hostile attackers may perform a MIM attack exploiting them. Everyone using the affected versions of make-ca should upgrade to make-ca-1.10, and run `make-ca -f -g` as the `root` user to regenerate the trusted store immediately. As a workaround, users may delete the untrusted certificates from /etc/pki/tls and /etc/ssl/certs manually (or by a script), but this is not recommended because the manual changes will be overwritten next time running make-ca to update the trusted anchor.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"/etc/pki/tls and /etc/ssl/certs include distrusted certificates in make-ca","id":"CVE-2022-21672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":0,"n_references":4,"next":{"headline":"OAuth Identity Token exposure in Grafana","id":"CVE-2022-21673"},"packages":[],"prev":{"headline":"Potential exposure of Replit tokens to an Unauthorized Actor in @replit/crosis","id":"CVE-2022-21671"},"products":["make-ca"],"published":"2022-01-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["lfs-book"]},"summary":"make-ca incorrectly trusts explicitly untrusted certificates, enabling man-in-the-middle attacks against systems using affected versions.","url":"https://insights.sbomify.com/CVE-2022-21672/"}