# CVE-2022-21672: /etc/pki/tls and /etc/ssl/certs include distrusted certificates in make-ca

> make-ca incorrectly trusts explicitly untrusted certificates, enabling man-in-the-middle attacks against systems using affected versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-m5qh-728v-4xrx

## What is CVE-2022-21672?

CVE-2022-21672 is a medium-severity vulnerability in lfs-book make-ca, published on 10 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

make-ca is a utility to deliver and manage a complete PKI configuration for workstations and servers. Starting with version 0.9 and prior to version 1.10, make-ca misinterprets Mozilla certdata.txt and treats explicitly untrusted certificates like trusted ones, causing those explicitly untrusted certificates trusted by the system. The explicitly untrusted certificates were used by some CAs already hacked. Hostile attackers may perform a MIM attack exploiting them. Everyone using the affected versions of make-ca should upgrade to make-ca-1.10, and run `make-ca -f -g` as the `root` user to regenerate the trusted store immediately. As a workaround, users may delete the untrusted certificates from /etc/pki/tls and /etc/ssl/certs manually (or by a script), but this is not recommended because the manual changes will be overwritten next time running make-ca to update the trusted anchor.

Weakness: CWE-115 (Misinterpretation of Input)

## Which versions are affected by CVE-2022-21672?

It affects 1 product.


Products: Linuxfromscratch Make-Ca.

## How do I fix CVE-2022-21672?

No fix has been published for CVE-2022-21672 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-21672 being exploited?

There is no known exploitation of CVE-2022-21672 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21672 and fix it if it is affected.

What it is: CVE-2022-21672 is a medium-severity vulnerability in lfs-book make-ca, published on 10 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21672 in the wild and no public exploit code.

Affected product: lfs-book make-ca. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21672/ (Markdown: https://insights.sbomify.com/CVE-2022-21672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21672
- OSV: https://osv.dev/vulnerability/CVE-2022-21672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21672/
Summaries are generated and may contain mistakes; the official description above is the record.
