CVE-2022-21676 Uncaught Exception in engine.io
A specially crafted HTTP request can crash the Node.js process in Engine.IO, causing denial of service for applications using this library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-21676?
CVE-2022-21676 is a high-severity denial of service vulnerability in socketio engine.io, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Engine.IO is the implementation of transport-based cross-browser/cross-device bi-directional communication layer for Socket.IO. A specially crafted HTTP request can trigger an uncaught exception on the Engine.IO server, thus killing the Node.js process. This impacts all the users of the `engine.io` package starting from version `4.0.0`, including those who uses depending packages like `socket.io`. Versions prior to `4.0.0` are not impacted. A fix has been released for each major branch, namely `4.1.2` for the `4.x.x` branch, `5.2.1` for the `5.x.x` branch, and `6.1.1` for the `6.x.x` branch. There is no known workaround except upgrading to a safe version.
Which versions are affected by CVE-2022-21676?
6 open source packages ship an affected version, including engine.io. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
engine.io npm | From 4.0.0 | 4.1.2 |
engine.io npm | From 4.0.0 | 4.1.2 |
engine.io npm | From 5.0.0 | 5.2.1 |
engine.io npm | From 5.0.0 | 5.2.1 |
engine.io npm | From 6.0.0 | 6.1.1 |
engine.io npm | From 6.0.0 | 6.1.1 |
Products include Socket Engine.io.
How do I fix CVE-2022-21676?
Upgrade engine.io to a fixed version for your release line: 4.1.2, 5.2.1 or 6.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-21676 being exploited?
There is no known exploitation of CVE-2022-21676 in the wild and no public exploit code.
Other vulnerabilities in socketio engine.io
Sources
Also known as GHSA-273r-mgr4-v34f.