# CVE-2022-21676: Uncaught Exception in engine.io

> A specially crafted HTTP request can crash the Node.js process in Engine.IO, causing denial of service for applications using this library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-273r-mgr4-v34f

## What is CVE-2022-21676?

CVE-2022-21676 is a high-severity denial of service vulnerability in socketio engine.io, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Engine.IO is the implementation of transport-based cross-browser/cross-device bi-directional communication layer for Socket.IO. A specially crafted HTTP request can trigger an uncaught exception on the Engine.IO server, thus killing the Node.js process. This impacts all the users of the `engine.io` package starting from version `4.0.0`, including those who uses depending packages like `socket.io`. Versions prior to `4.0.0` are not impacted. A fix has been released for each major branch, namely `4.1.2` for the `4.x.x` branch, `5.2.1` for the `5.x.x` branch, and `6.1.1` for the `6.x.x` branch. There is no known workaround except upgrading to a safe version.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2022-21676?

6 open source packages ship an affected version, including engine.io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `engine.io` | npm | From 4.0.0 | 4.1.2 |
| `engine.io` | npm | From 4.0.0 | 4.1.2 |
| `engine.io` | npm | From 5.0.0 | 5.2.1 |
| `engine.io` | npm | From 5.0.0 | 5.2.1 |
| `engine.io` | npm | From 6.0.0 | 6.1.1 |
| `engine.io` | npm | From 6.0.0 | 6.1.1 |

Products: Socket Engine.io.

## How do I fix CVE-2022-21676?

Upgrade engine.io to a fixed version for your release line: 4.1.2, 5.2.1 or 6.1.1.

## Is CVE-2022-21676 being exploited?

There is no known exploitation of CVE-2022-21676 in the wild and no public exploit code.

## Other vulnerabilities in socketio engine.io

- [CVE-2026-59724](https://insights.sbomify.com/CVE-2026-59724/): Socket.IO: Engine.IO WebTransport SID DoS (high 7.5)
- [CVE-2026-59725](https://insights.sbomify.com/CVE-2026-59725/): Socket.IO: Engine.IO Polling Transport Connection Exhaustion (high 7.5)
- [CVE-2020-36048](https://insights.sbomify.com/CVE-2020-36048/): Resource exhaustion in engine.io (high 7.5)
- [CVE-2022-41940](https://insights.sbomify.com/CVE-2022-41940/): Uncaught exception in engine.io (high 7.1)
- [CVE-2023-31125](https://insights.sbomify.com/CVE-2023-31125/): Uncaught exception in engine.io (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21676 and fix it if it is affected.

What it is: CVE-2022-21676 is a high-severity denial of service vulnerability in socketio engine.io, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21676 in the wild and no public exploit code.

Affected packages and fixed versions:
- engine.io (npm): affected from 4.0.0; fixed in 4.1.2
- engine.io (npm): affected from 4.0.0; fixed in 4.1.2
- engine.io (npm): affected from 5.0.0; fixed in 5.2.1
- engine.io (npm): affected from 5.0.0; fixed in 5.2.1
- engine.io (npm): affected from 6.0.0; fixed in 6.1.1
- engine.io (npm): affected from 6.0.0; fixed in 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21676/ (Markdown: https://insights.sbomify.com/CVE-2022-21676/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21676
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21676
- OSV: https://osv.dev/vulnerability/CVE-2022-21676

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21676/
Summaries are generated and may contain mistakes; the official description above is the record.
