{"answers":{"affected":"1 open source package ship an affected version, including discourse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21677 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-21677 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-21677 is a medium-severity vulnerability in Discourse Discourse, published on 14 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-21677 and fix it if it is affected.\n\nWhat it is: CVE-2022-21677 is a medium-severity vulnerability in Discourse Discourse, published on 14 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-21677 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected all versions up to 2.7.12; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21677/ (Markdown: https://insights.sbomify.com/CVE-2022-21677/index.md)","id":"CVE-2022-21677","markdown":"https://insights.sbomify.com/CVE-2022-21677/index.md","name":"CVE-2022-21677","record":{"aliases":["BIT-discourse-2022-21677","GHSA-768r-ppv4-5r27"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Discourse forum platform","requires_auth":"none","summary":"Attackers can reveal restricted group and member visibility settings via advanced search, exposing private data in Discourse forums.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"discourse","vendor":"discourse"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Discourse is an open source discussion platform. Discourse groups can be configured with varying visibility levels for the group as well as the group members. By default, a newly created group has its visibility set to public and the group's members visibility set to public as well. However, a group's visibility and the group's members visibility can be configured such that it is restricted to logged on users, members of the group or staff users. A vulnerability has been discovered in versions prior to 2.7.13 and 2.8.0.beta11 where the group advanced search option does not respect the group's visibility and members visibility level. As such, a group with restricted visibility or members visibility can be revealed through search with the right search option. This issue is patched in `stable` version 2.7.13, `beta` version 2.8.0.beta11, and `tests-passed` version 2.8.0.beta11 versions of Discourse. There are no workarounds aside from upgrading.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Group advanced search option may leak group and group's members visibility","id":"CVE-2022-21677","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"discourse:discourse","products":["discourse:discourse"],"type":"information_disclosure","year":"2022"},"n_packages":1,"n_references":2,"next":{"headline":"User's bio visible even if profile is restricted in Discourse","id":"CVE-2022-21678"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["0"],"last_affected":["2.7.12"],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2022-21677"}],"prev":{"headline":"Uncaught Exception in engine.io","id":"CVE-2022-21676"},"products":["discourse"],"published":"2022-01-14","related":[{"cvss_score":10,"headline":"RCE via malicious SNS subscription payload","id":"CVE-2021-41163","kev_date_added":null,"published":"2021-10-20"},{"cvss_score":9.1,"headline":"Discourse vulnerable to RCE via admins uploading maliciously zipped file","id":"CVE-2022-36066","kev_date_added":null,"published":"2022-09-29"},{"cvss_score":8.9,"headline":"Discourse user account takeover via email and invite link","id":"CVE-2022-39356","kev_date_added":null,"published":"2022-11-02"},{"cvss_score":8.8,"headline":"Discourse vulnerable to Cross-site Scripting in local oneboxes","id":"CVE-2023-22468","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":8.7,"headline":"Discourse leaks private topic title and post excerpt via user action API endpoint","id":"CVE-2026-27934","kev_date_added":null,"published":"2026-03-19"},{"cvss_score":8.7,"headline":"Discourse vulnerable to DoS via large URL payload in PM to a bot","id":"CVE-2025-48053","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.6,"headline":"Discourse vulnerable to unlimited mentioned users in message serializer","id":"CVE-2023-48297","kev_date_added":null,"published":"2024-01-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["discourse"]},"summary":"Attackers can reveal restricted group and member visibility settings via advanced search, exposing private data in Discourse forums.","url":"https://insights.sbomify.com/CVE-2022-21677/"}