{"answers":{"affected":"2 open source packages ship an affected version, including marked. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21680 exists.","fix":"Upgrade marked to 4.0.10 or later.","what":"CVE-2022-21680 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 14 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21680 and fix it if it is affected.\n\nWhat it is: CVE-2022-21680 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 14 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21680 exists.\n\nAffected packages and fixed versions:\n- marked (npm): affected all versions; fixed in 4.0.10\n- marked (npm): affected all versions; fixed in 4.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21680/ (Markdown: https://insights.sbomify.com/CVE-2022-21680/index.md)","id":"CVE-2022-21680","markdown":"https://insights.sbomify.com/CVE-2022-21680/index.md","name":"CVE-2022-21680","record":{"aliases":["CLSA-2026-1770682160","CLSA-2026-1777077481","CLSA-2026-1792163530","DEBIAN-CVE-2022-21680","GHSA-rrrm-qjm4-v8hf","ROOT-APP-NPM-CVE-2022-21680","UBUNTU-CVE-2022-21680"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript markdown parser","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the marked library by submitting crafted markdown that triggers catastrophic regex backtracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"marked","vendor":"marked_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `block.def` may cause catastrophic backtracking against some strings and lead to a regular expression denial of service (ReDoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cubic catastrophic backtracking (ReDoS) in marked","id":"CVE-2022-21680","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Exponential catastrophic backtracking (ReDoS) in marked","id":"CVE-2022-21681"},"packages":[{"ecosystem":"npm","fixed":["4.0.10"],"introduced":["0"],"last_affected":[],"package":"marked","purl":null,"source":"GHSA-rrrm-qjm4-v8hf"},{"ecosystem":"npm","fixed":["4.0.10"],"introduced":["0"],"last_affected":[],"package":"marked","purl":"pkg:npm/marked","source":"GHSA-rrrm-qjm4-v8hf"}],"prev":{"headline":"Authorization Policy bypass in Istio","id":"CVE-2022-21679"},"products":["marked"],"published":"2022-01-14","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["markedjs"]},"summary":"Attackers can cause denial of service in applications using the marked library by submitting crafted markdown that triggers catastrophic regex backtracking.","url":"https://insights.sbomify.com/CVE-2022-21680/"}