# CVE-2022-21680: Cubic catastrophic backtracking (ReDoS) in marked

> Attackers can cause denial of service in applications using the marked library by submitting crafted markdown that triggers catastrophic regex backtracking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2022
- **Updated:** 22 Apr 2025
- **Also known as:** CLSA-2026-1770682160, CLSA-2026-1777077481, CLSA-2026-1792163530, DEBIAN-CVE-2022-21680, GHSA-rrrm-qjm4-v8hf, ROOT-APP-NPM-CVE-2022-21680, UBUNTU-CVE-2022-21680

## What is CVE-2022-21680?

CVE-2022-21680 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 14 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `block.def` may cause catastrophic backtracking against some strings and lead to a regular expression denial of service (ReDoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-21680?

2 open source packages ship an affected version, including marked. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `marked` | npm | All versions | 4.0.10 |
| `marked` | npm | All versions | 4.0.10 |

Products: Fedoraproject Fedora, Marked Project Marked.

## How do I fix CVE-2022-21680?

Upgrade marked to 4.0.10 or later.

## Is CVE-2022-21680 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21680 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21680 and fix it if it is affected.

What it is: CVE-2022-21680 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 14 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21680 exists.

Affected packages and fixed versions:
- marked (npm): affected all versions; fixed in 4.0.10
- marked (npm): affected all versions; fixed in 4.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21680/ (Markdown: https://insights.sbomify.com/CVE-2022-21680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21680
- OSV: https://osv.dev/vulnerability/CVE-2022-21680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21680/
Summaries are generated and may contain mistakes; the official description above is the record.
