# CVE-2022-21683: Comment reply notifications sent to incorrect users in wagtail

> Attackers can receive notifications for comment replies on pages they lack access to, leaking private content to unauthorized users.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-xqxm-2rpm-3889, PYSEC-2022-13

## What is CVE-2022-21683?

CVE-2022-21683 is a low-severity vulnerability in wagtail, published on 18 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Wagtail is a Django based content management system focused on flexibility and user experience. When notifications for new replies in comment threads are sent, they are sent to all users who have replied or commented anywhere on the site, rather than only in the relevant threads. This means that a user could listen in to new comment replies on pages they have not have editing access to, as long as they have left a comment or reply somewhere on the site. A patched version has been released as Wagtail 2.15.2, which restores the intended behaviour - to send notifications for new replies to the participants in the active thread only (editing permissions are not considered). New comments can be disabled by setting `WAGTAILADMIN_COMMENTS_ENABLED = False` in the Django settings file.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-21683?

3 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | From 2.13 | 2.15.2 |
| `wagtail` | PyPI | From 2.13 | 2.15.2 |
| `wagtail` | PyPI | From 2.13 | 2.15.2 |

Products: Torchbox Wagtail.

## How do I fix CVE-2022-21683?

Upgrade wagtail to 2.15.2 or later.

## Is CVE-2022-21683 being exploited?

There is no known exploitation of CVE-2022-21683 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21683 and fix it if it is affected.

What it is: CVE-2022-21683 is a low-severity vulnerability in wagtail, published on 18 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-21683 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected from 2.13; fixed in 2.15.2
- wagtail (PyPI): affected from 2.13; fixed in 2.15.2
- wagtail (PyPI): affected from 2.13; fixed in 2.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21683/ (Markdown: https://insights.sbomify.com/CVE-2022-21683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21683
- OSV: https://osv.dev/vulnerability/CVE-2022-21683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21683/
Summaries are generated and may contain mistakes; the official description above is the record.
