CVE-2022-21684 User can bypass approval when invited to Discourse

Medium 4.3 Published Updated

Invited users can bypass approval requirements to access Discourse forums with full privileges before being approved.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-21684?

CVE-2022-21684 is a medium-severity authentication bypass vulnerability in Discourse Discourse, published on 13 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Versions prior to 2.7.13 in `stable`, 2.8.0.beta11 in `beta`, and 2.8.0.beta11 in `tests-passed` allow some users to log in to a community before they should be able to do so. A user invited via email to a forum with `must_approve_users` enabled is going to be automatically logged in, bypassing the check that does not allow unapproved users to sign in. They will be able to do everything an approved user can do. If they logout, they cannot log back in. This issue is patched in the `stable` version 2.7.13, `beta` version 2.8.0.beta11, and `tests-passed` version 2.8.0.beta11. One may disable invites as a workaround. Administrators can increase `min_trust_level_to_allow_invite` to reduce the attack surface to more trusted users.

Weakness: CWE-287

Which versions are affected by CVE-2022-21684?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.7.13

Products include Discourse Discourse.

How do I fix CVE-2022-21684?

Upgrade discourse to 2.7.13 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-21684 being exploited?

There is no known exploitation of CVE-2022-21684 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-21684, GHSA-p63q-jp48-h8xh.

Is CVE-2022-21684 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free