# CVE-2022-21684: User can bypass approval when invited to Discourse

> Invited users can bypass approval requirements to access Discourse forums with full privileges before being approved.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-discourse-2022-21684, GHSA-p63q-jp48-h8xh

## What is CVE-2022-21684?

CVE-2022-21684 is a medium-severity authentication bypass vulnerability in Discourse Discourse, published on 13 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source discussion platform. Versions prior to 2.7.13 in `stable`, 2.8.0.beta11 in `beta`, and 2.8.0.beta11 in `tests-passed` allow some users to log in to a community before they should be able to do so. A user invited via email to a forum with `must_approve_users` enabled is going to be automatically logged in, bypassing the check that does not allow unapproved users to sign in. They will be able to do everything an approved user can do. If they logout, they cannot log back in. This issue is patched in the `stable` version 2.7.13, `beta` version 2.8.0.beta11, and `tests-passed` version 2.8.0.beta11. One may disable invites as a workaround. Administrators can increase `min_trust_level_to_allow_invite` to reduce the attack surface to more trusted users.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-21684?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.7.13 |

Products: Discourse Discourse.

## How do I fix CVE-2022-21684?

Upgrade discourse to 2.7.13 or later.

## Is CVE-2022-21684 being exploited?

There is no known exploitation of CVE-2022-21684 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21684 and fix it if it is affected.

What it is: CVE-2022-21684 is a medium-severity authentication bypass vulnerability in Discourse Discourse, published on 13 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21684 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.7.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21684/ (Markdown: https://insights.sbomify.com/CVE-2022-21684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21684
- OSV: https://osv.dev/vulnerability/CVE-2022-21684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21684/
Summaries are generated and may contain mistakes; the official description above is the record.
