{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21686 in the wild and no public exploit code.","fix":"Upgrade prestashop/prestashop to 1.7.8.3 or later.","what":"CVE-2022-21686 is a critical code injection vulnerability in Prestashop Prestashop, published on 26 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21686 and fix it if it is affected.\n\nWhat it is: CVE-2022-21686 is a critical code injection vulnerability in Prestashop Prestashop, published on 26 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21686 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected from 1.7.0.0; fixed in 1.7.8.3\n- prestashop/prestashop (Packagist): affected from 1.7.0.0; fixed in 1.7.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21686/ (Markdown: https://insights.sbomify.com/CVE-2022-21686/index.md)","id":"CVE-2022-21686","markdown":"https://insights.sbomify.com/CVE-2022-21686/index.md","name":"CVE-2022-21686","record":{"aliases":["GHSA-mrq4-7ch7-2465"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PrestaShop e-commerce platform","requires_auth":"none","summary":"Attackers can inject Twig code in the PrestaShop back office when using the legacy layout, leading to remote code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop","vendor":"prestashop"}],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"PrestaShop is an Open Source e-commerce platform. Starting with version 1.7.0.0 and ending with version 1.7.8.3, an attacker is able to inject twig code inside the back office when using the legacy layout. The problem is fixed in version 1.7.8.3. There are no known workarounds.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server Side Twig Template Injection in PrestaShop","id":"CVE-2022-21686","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"prestashop:prestashop","products":["prestashop:prestashop"],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Command injection in gh-ost","id":"CVE-2022-21687"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.8.3"],"introduced":["1.7.0.0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-mrq4-7ch7-2465"},{"ecosystem":"Packagist","fixed":["1.7.8.3"],"introduced":["1.7.0.0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-mrq4-7ch7-2465"}],"prev":{"headline":"Integer underflow in Frontier","id":"CVE-2022-21685"},"products":["PrestaShop"],"published":"2022-01-26","related":[{"cvss_score":10,"headline":"PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using \"SQL Manager\"","id":"CVE-2023-30839","kev_date_added":null,"published":"2023-04-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-5791","kev_date_added":null,"published":"2008-12-31"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2024-41651","kev_date_added":null,"published":"2024-08-12"},{"cvss_score":9.8,"headline":"Remote code execution in prestashop","id":"CVE-2022-31181","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-3110","kev_date_added":null,"published":"2021-01-20"},{"cvss_score":9.8,"headline":"Blind SQL Injection in PrestaShop","id":"CVE-2020-15160","kev_date_added":null,"published":"2020-09-24"},{"cvss_score":9.8,"headline":"Privilege escalation in n/a","id":"CVE-2013-6295","kev_date_added":null,"published":"2020-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["PrestaShop"]},"summary":"Attackers can inject Twig code in the PrestaShop back office when using the legacy layout, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2022-21686/"}