# CVE-2022-21687: Command injection in gh-ost

> Attackers can read arbitrary files by exploiting unsanitized input in the database parameter of gh-ost, requiring host access or social engineering.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2022
- **Updated:** 5 May 2025
- **Also known as:** GHSA-rrp4-2xx3-mv29, GO-2022-0298

## What is CVE-2022-21687?

CVE-2022-21687 is a medium-severity command injection vulnerability in n/a, published on 1 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

gh-ost is a triggerless online schema migration solution for MySQL. Versions prior to 1.1.3 are subject to an arbitrary file read vulnerability. The attacker must have access to the target host or trick an administrator into executing a malicious gh-ost command on a host running gh-ost, plus network access from host running gh-ost to the attack's malicious MySQL server. The `-database` parameter does not properly sanitize user input which can lead to arbitrary file reads.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-21687?

3 open source packages ship an affected version, including github.com/github/gh-ost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/github/gh-ost` | Go | All versions | 1.1.3 |
| `github.com/github/gh-ost` | Go | All versions | 1.1.3 |
| `github.com/github/gh-ost` | Go | All versions | 1.1.3 |

Products: Github Gh-Ost.

## How do I fix CVE-2022-21687?

Upgrade github.com/github/gh-ost to 1.1.3 or later.

## Is CVE-2022-21687 being exploited?

There is no known exploitation of CVE-2022-21687 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21687 and fix it if it is affected.

What it is: CVE-2022-21687 is a medium-severity command injection vulnerability in n/a, published on 1 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21687 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/github/gh-ost (Go): affected all versions; fixed in 1.1.3
- github.com/github/gh-ost (Go): affected all versions; fixed in 1.1.3
- github.com/github/gh-ost (Go): affected all versions; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21687/ (Markdown: https://insights.sbomify.com/CVE-2022-21687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21687
- OSV: https://osv.dev/vulnerability/CVE-2022-21687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21687/
Summaries are generated and may contain mistakes; the official description above is the record.
