# CVE-2022-21688: Out-of-bounds Read in Onionshare

> An attacker can cause a denial of service in OnionShare by triggering excessive memory consumption via malicious image data in the history tab.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-x7wr-283h-5h2v, PYSEC-2022-39, UBUNTU-CVE-2022-21688

## What is CVE-2022-21688?

CVE-2022-21688 is a high-severity denial of service vulnerability in onionshare, published on 18 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OnionShare is an open source tool that lets you securely and anonymously share files, host websites, and chat with friends using the Tor network. Affected versions of the desktop application were found to be vulnerable to denial of service via an undisclosed vulnerability in the QT image parsing. Roughly 20 bytes lead to 2GB memory consumption and this can be triggered multiple times. To be abused, this vulnerability requires rendering in the history tab, so some user interaction is required. An adversary with knowledge of the Onion service address in public mode or with authentication in private mode can perform a Denial of Service attack, which quickly results in out-of-memory for the server. This requires the desktop application with rendered history, therefore the impact is only elevated. This issue has been patched in version 2.5.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-21688?

3 open source packages ship an affected version, including onionshare-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onionshare-cli` | PyPI | All versions | 2.5 |
| `onionshare-cli` | PyPI | All versions | 2.5 |
| `onionshare-cli` | PyPI | All versions | 2.5 |

Products: Onionshare Onionshare.

## How do I fix CVE-2022-21688?

Upgrade onionshare-cli to 2.5 or later.

## Is CVE-2022-21688 being exploited?

There is no known exploitation of CVE-2022-21688 in the wild and no public exploit code.

## Other vulnerabilities in onionshare

- [CVE-2021-41868](https://insights.sbomify.com/CVE-2021-41868/): Remote unauthenticated attackers able to upload files in Onionshare (critical 9.8)
- [CVE-2022-21690](https://insights.sbomify.com/CVE-2022-21690/): Cross-Site Scripting in Onionshare (high 8.7)
- [CVE-2022-21689](https://insights.sbomify.com/CVE-2022-21689/): Denial of Service in Onionshare (high 7.5)
- [CVE-2018-19960](https://insights.sbomify.com/CVE-2018-19960/): Path traversal in n/a (high 7.0)
- [CVE-2022-21693](https://insights.sbomify.com/CVE-2022-21693/): Path traversal in Onionshare (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21688 and fix it if it is affected.

What it is: CVE-2022-21688 is a high-severity denial of service vulnerability in onionshare, published on 18 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21688 in the wild and no public exploit code.

Affected packages and fixed versions:
- onionshare-cli (PyPI): affected all versions; fixed in 2.5
- onionshare-cli (PyPI): affected all versions; fixed in 2.5
- onionshare-cli (PyPI): affected all versions; fixed in 2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21688/ (Markdown: https://insights.sbomify.com/CVE-2022-21688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21688
- OSV: https://osv.dev/vulnerability/CVE-2022-21688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21688/
Summaries are generated and may contain mistakes; the official description above is the record.
