{"answers":{"affected":"3 open source packages ship an affected version, including jupyter-server-proxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21697 in the wild and no public exploit code.","fix":"Upgrade jupyter-server-proxy to 3.2.1 or later.","what":"CVE-2022-21697 is a medium-severity server-side request forgery vulnerability in jupyterhub jupyter-server-proxy, published on 25 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-21697 and fix it if it is affected.\n\nWhat it is: CVE-2022-21697 is a medium-severity server-side request forgery vulnerability in jupyterhub jupyter-server-proxy, published on 25 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-21697 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.1\n- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.1\n- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21697/ (Markdown: https://insights.sbomify.com/CVE-2022-21697/index.md)","id":"CVE-2022-21697","markdown":"https://insights.sbomify.com/CVE-2022-21697/index.md","name":"CVE-2022-21697","record":{"aliases":["GHSA-gcv9-6737-pjqw","PYSEC-2022-16"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jupyter server extension","requires_auth":"low_privilege","summary":"Authenticated users can bypass host restrictions to perform server-side request forgery in Jupyter Server Proxy.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jupyter_server_proxy","vendor":"jupyter"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SSRF vulnerability (requires authentication)","id":"CVE-2022-21697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Uncontrolled Resource Consumption in promhttp","id":"CVE-2022-21698"},"packages":[{"ecosystem":"PyPI","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"jupyter-server-proxy","purl":null,"source":"GHSA-gcv9-6737-pjqw"},{"ecosystem":"PyPI","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"jupyter-server-proxy","purl":"pkg:pypi/jupyter-server-proxy","source":"GHSA-gcv9-6737-pjqw"},{"ecosystem":"PyPI","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"jupyter-server-proxy","purl":"pkg:pypi/jupyter-server-proxy","source":"PYSEC-2022-16"}],"prev":{"headline":"Username spoofing in OnionShare","id":"CVE-2022-21696"},"products":["jupyter-server-proxy"],"published":"2022-01-25","related":[{"cvss_score":9.7,"headline":"Jupyter Server Proxy has a reflected XSS issue in host parameter","id":"CVE-2024-35225","kev_date_added":null,"published":"2024-06-11"},{"cvss_score":9.1,"headline":"Jupyter Server Proxy's Websocket Proxying does not require authentication","id":"CVE-2024-28179","kev_date_added":null,"published":"2024-03-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["jupyterhub"]},"summary":"Authenticated users can bypass host restrictions to perform server-side request forgery in Jupyter Server Proxy.","url":"https://insights.sbomify.com/CVE-2022-21697/"}