# CVE-2022-21707: Incorrect Authorization in wasmCloud

> Attackers can bypass capability authorization in wasmCloud Host Runtime, allowing unauthorized invocations from linked capability providers.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-2cmx-rr54-88g5

## What is CVE-2022-21707?

CVE-2022-21707 is a medium-severity missing authorization vulnerability in wasmcloud-otp, published on 21 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

wasmCloud Host Runtime is a server process that securely hosts and provides dispatch for web assembly (WASM) actors and capability providers. In versions prior to 0.52.2 actors can bypass capability authorization. Actors are normally required to declare their capabilities for inbound invocations, but with this vulnerability actor capability claims are not verified upon receiving invocations. This compromises the security model for actors as they can receive unauthorized invocations from linked capability providers. The problem has been patched in versions `0.52.2` and greater. There is no workaround and users are advised to upgrade to an unaffected version as soon as possible.

Weakness: CWE-862 (Missing Authorization), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-21707?

It affects 1 product.


Products: Wasmcloud Host Runtime.

## How do I fix CVE-2022-21707?

No fix has been published for CVE-2022-21707 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-21707 being exploited?

There is no known exploitation of CVE-2022-21707 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21707 and fix it if it is affected.

What it is: CVE-2022-21707 is a medium-severity missing authorization vulnerability in wasmcloud-otp, published on 21 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21707 in the wild and no public exploit code.

Affected product: wasmcloud-otp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21707/ (Markdown: https://insights.sbomify.com/CVE-2022-21707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21707
- OSV: https://osv.dev/vulnerability/CVE-2022-21707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21707/
Summaries are generated and may contain mistakes; the official description above is the record.
