# CVE-2022-21712: Cookie and header exposure in twisted

> Attackers can steal cookies and authorization headers when the Twisted library follows cross-origin redirects, potentially leading to session hijacking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** AZL-8505, DEBIAN-CVE-2022-21712, GHSA-92x2-jw7w-xvvx, PYSEC-2022-27, SUSE-SU-2022:0499-1, SUSE-SU-2022:0734-1, UBUNTU-CVE-2022-21712, openSUSE-SU-2022:0499-1, openSUSE-SU-2024:11841-1

## What is CVE-2022-21712?

CVE-2022-21712 is a high-severity vulnerability in Debian Debian Linux, published on 7 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

twisted is an event-driven networking engine written in Python. In affected versions twisted exposes cookies and authorization headers when following cross-origin redirects. This issue is present in the `twited.web.RedirectAgent` and `twisted.web. BrowserLikeRedirectAgent` functions. Users are advised to upgrade. There are no known workarounds.

Weakness: CWE-346 (Origin Validation Error), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-21712?

3 open source packages ship an affected version, including twisted and Twisted. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | From 11.1.0 | 22.1.0 |
| `twisted` | PyPI | From 11.1.0 | 22.1.0 |
| `Twisted` | PyPI | From 11.1.0 | 22.1.0 |
| `python-Twisted` | SUSE:Enterprise Storage 7 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:HPE Helion OpenStack 8 | All versions | 15.2.1-9.11.1 |
| `python-Twisted` | SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 15.2.1-9.11.1 |
| `python-Twisted` | SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Manager Proxy 4.1 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Manager Retail Branch Server 4.1 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:Manager Server 4.1 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | SUSE:OpenStack Cloud 8 | All versions | 15.2.1-9.11.1 |
| `python-Twisted` | SUSE:OpenStack Cloud 9 | All versions | 15.2.1-9.11.1 |
| `python-Twisted` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 15.2.1-9.11.1 |
| `python-Twisted` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 15.2.1-9.11.1 |
| `python-Twisted` | openSUSE:Leap 15.3 | All versions | 19.10.0-3.6.1 |
| `python-Twisted` | openSUSE:Tumbleweed | All versions | 22.1.0-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Twisted Twisted.

## How do I fix CVE-2022-21712?

Upgrade twisted to 22.1.0 or later.

## Is CVE-2022-21712 being exploited?

There is no known exploitation of CVE-2022-21712 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21712 and fix it if it is affected.

What it is: CVE-2022-21712 is a high-severity vulnerability in Debian Debian Linux, published on 7 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21712 in the wild and no public exploit code.

Affected packages and fixed versions:
- twisted (PyPI): affected from 11.1.0; fixed in 22.1.0
- twisted (PyPI): affected from 11.1.0; fixed in 22.1.0
- Twisted (PyPI): affected from 11.1.0; fixed in 22.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21712/ (Markdown: https://insights.sbomify.com/CVE-2022-21712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21712
- OSV: https://osv.dev/vulnerability/CVE-2022-21712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21712/
Summaries are generated and may contain mistakes; the official description above is the record.
