# CVE-2022-21715: Cross-site Scripting Vulnerability in CodeIgniter4

> Attackers can execute arbitrary scripts in victims' browsers via XSS in CodeIgniter4's API ResponseTrait, requiring framework users to patch.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-codeigniter-2022-21715, GHSA-7528-7jg5-6g62

## What is CVE-2022-21715?

CVE-2022-21715 is a medium-severity cross-site scripting vulnerability in CodeIgniter4, published on 24 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A cross-site scripting (XSS) vulnerability was found in `API\ResponseTrait` in Codeigniter4 prior to version 4.1.8. Attackers can do XSS attacks if a potential victim is using `API\ResponseTrait`. Version 4.1.8 contains a patch for this vulnerability. There are two potential workarounds available. Users may avoid using `API\ResponseTrait` or `ResourceController` Users may also disable Auto Route and use defined routes only.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-21715?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.1.8 |
| `codeigniter4/framework` | Packagist | All versions | 4.1.8 |
| `codeigniter` | Bitnami | From 4.0.0 | 4.1.8 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2022-21715?

Upgrade codeigniter4/framework to 4.1.8 or later.

## Is CVE-2022-21715 being exploited?

There is no known exploitation of CVE-2022-21715 in the wild and no public exploit code.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21715 and fix it if it is affected.

What it is: CVE-2022-21715 is a medium-severity cross-site scripting vulnerability in CodeIgniter4, published on 24 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-21715 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.8
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.1.8
- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21715/ (Markdown: https://insights.sbomify.com/CVE-2022-21715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21715
- OSV: https://osv.dev/vulnerability/CVE-2022-21715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21715/
Summaries are generated and may contain mistakes; the official description above is the record.
