CVE-2022-21716 Buffer Overflow in Twisted
An attacker can cause a denial of service by sending excessive data to the SSH version identifier, exhausting memory in the Twisted framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-21716?
CVE-2022-21716 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 22.2.0, Twisted SSH client and server implement is able to accept an infinite amount of data for the peer's SSH version identifier. This ends up with a buffer using all the available memory. The attach is a simple as `nc -rv localhost 22 < /dev/zero`. A patch is available in version 22.2.0. There are currently no known workarounds.
Which versions are affected by CVE-2022-21716?
3 open source packages ship an affected version, including twisted. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
twisted PyPI | From 21.7.0 | 22.2.0 |
twisted PyPI | From 21.7.0 | 22.2.0 |
twisted PyPI | From 21.7.0 | 22.2.0 |
Linux distribution packages (21)
python-Twisted SUSE:Enterprise Storage 7 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:HPE Helion OpenStack 8 | All versions | 15.2.1-9.17.1 |
python-Twisted SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 22.2.0-150400.5.4.1 |
python-Twisted SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 15.2.1-9.17.1 |
python-Twisted SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Manager Proxy 4.1 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Manager Retail Branch Server 4.1 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:Manager Server 4.1 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted SUSE:OpenStack Cloud 8 | All versions | 15.2.1-9.17.1 |
python-Twisted SUSE:OpenStack Cloud 9 | All versions | 15.2.1-9.17.1 |
python-Twisted SUSE:OpenStack Cloud Crowbar 8 | All versions | 15.2.1-9.17.1 |
python-Twisted SUSE:OpenStack Cloud Crowbar 9 | All versions | 15.2.1-9.17.1 |
python-Twisted openSUSE:Leap 15.3 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted openSUSE:Leap 15.4 | All versions | 19.10.0-150200.3.12.1 |
python-Twisted openSUSE:Leap 15.4 | All versions | 22.2.0-150400.5.4.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Oracle Http Server, Oracle Zfs Storage Appliance Kit, Twisted Twisted.
How do I fix CVE-2022-21716?
Upgrade twisted to 22.2.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-21716 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21716 exists.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2022-21716, DLA-2938-1, GHSA-rv6r-3f5q-9rgx, PYSEC-2022-160, SUSE-SU-2022:2070-1, SUSE-SU-2022:2117-1 and 3 more.