# CVE-2022-21716: Buffer Overflow in Twisted

> An attacker can cause a denial of service by sending excessive data to the SSH version identifier, exhausting memory in the Twisted framework.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-21716, DLA-2938-1, GHSA-rv6r-3f5q-9rgx, PYSEC-2022-160, SUSE-SU-2022:2070-1, SUSE-SU-2022:2117-1, SUSE-SU-2022:2297-1, UBUNTU-CVE-2022-21716, USN-5354-2

## What is CVE-2022-21716?

CVE-2022-21716 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 22.2.0, Twisted SSH client and server implement is able to accept an infinite amount of data for the peer's SSH version identifier. This ends up with a buffer using all the available memory. The attach is a simple as `nc -rv localhost 22 < /dev/zero`. A patch is available in version 22.2.0. There are currently no known workarounds.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2022-21716?

3 open source packages ship an affected version, including twisted. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | From 21.7.0 | 22.2.0 |
| `twisted` | PyPI | From 21.7.0 | 22.2.0 |
| `twisted` | PyPI | From 21.7.0 | 22.2.0 |
| `python-Twisted` | SUSE:Enterprise Storage 7 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:HPE Helion OpenStack 8 | All versions | 15.2.1-9.17.1 |
| `python-Twisted` | SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 22.2.0-150400.5.4.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 15.2.1-9.17.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Manager Proxy 4.1 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Manager Retail Branch Server 4.1 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:Manager Server 4.1 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | SUSE:OpenStack Cloud 8 | All versions | 15.2.1-9.17.1 |
| `python-Twisted` | SUSE:OpenStack Cloud 9 | All versions | 15.2.1-9.17.1 |
| `python-Twisted` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 15.2.1-9.17.1 |
| `python-Twisted` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 15.2.1-9.17.1 |
| `python-Twisted` | openSUSE:Leap 15.3 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | openSUSE:Leap 15.4 | All versions | 19.10.0-150200.3.12.1 |
| `python-Twisted` | openSUSE:Leap 15.4 | All versions | 22.2.0-150400.5.4.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Oracle Http Server, Oracle Zfs Storage Appliance Kit, Twisted Twisted.

## How do I fix CVE-2022-21716?

Upgrade twisted to 22.2.0 or later.

## Is CVE-2022-21716 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21716 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21716 and fix it if it is affected.

What it is: CVE-2022-21716 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21716 exists.

Affected packages and fixed versions:
- twisted (PyPI): affected from 21.7.0; fixed in 22.2.0
- twisted (PyPI): affected from 21.7.0; fixed in 22.2.0
- twisted (PyPI): affected from 21.7.0; fixed in 22.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21716/ (Markdown: https://insights.sbomify.com/CVE-2022-21716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21716
- OSV: https://osv.dev/vulnerability/CVE-2022-21716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21716/
Summaries are generated and may contain mistakes; the official description above is the record.
