# CVE-2022-21718: Renderers can obtain access to random bluetooth device without permission in Electron

> Renderers can access random Bluetooth devices without permission if the app lacks a custom device selection handler, exposing sensitive hardware data.

- **Severity:** Low 3.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-3p22-ghq8-v749

## What is CVE-2022-21718?

CVE-2022-21718 is a low-severity missing authorization vulnerability in Electronjs Electron, published on 22 Mar 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. A vulnerability in versions prior to `17.0.0-alpha.6`, `16.0.6`, `15.3.5`, `14.2.4`, and `13.6.6` allows renderers to obtain access to a bluetooth device via the web bluetooth API if the app has not configured a custom `select-bluetooth-device` event handler. This has been patched and Electron versions `17.0.0-alpha.6`, `16.0.6`, `15.3.5`, `14.2.4`, and `13.6.6` contain the fix. Code from the GitHub Security Advisory can be added to the app to work around the issue.

Weakness: CWE-862 (Missing Authorization), CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2022-21718?

10 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 13.6.6 |
| `electron` | npm | All versions | 13.6.6 |
| `electron` | npm | From 14.0.0-beta.1 | 14.2.4 |
| `electron` | npm | From 14.0.0-beta.1 | 14.2.4 |
| `electron` | npm | From 15.0.0-beta.1 | 15.3.5 |
| `electron` | npm | From 15.0.0-beta.1 | 15.3.5 |
| `electron` | npm | From 16.0.0-beta.1 | 16.0.6 |
| `electron` | npm | From 16.0.0-beta.1 | 16.0.6 |
| `electron` | npm | From 17.0.0-alpha.1 | 17.0.0-alpha.6 |
| `electron` | npm | From 17.0.0-alpha.1 | 17.0.0-alpha.6 |

Products: Electronjs Electron.

## How do I fix CVE-2022-21718?

Upgrade electron to a fixed version for your release line: 13.6.6, 14.2.4, 15.3.5 or 16.0.6.

## Is CVE-2022-21718 being exploited?

There is no known exploitation of CVE-2022-21718 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21718 and fix it if it is affected.

What it is: CVE-2022-21718 is a low-severity missing authorization vulnerability in Electronjs Electron, published on 22 Mar 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-21718 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 13.6.6
- electron (npm): affected all versions; fixed in 13.6.6
- electron (npm): affected from 14.0.0-beta.1; fixed in 14.2.4
- electron (npm): affected from 14.0.0-beta.1; fixed in 14.2.4
- electron (npm): affected from 15.0.0-beta.1; fixed in 15.3.5
- electron (npm): affected from 15.0.0-beta.1; fixed in 15.3.5
- electron (npm): affected from 16.0.0-beta.1; fixed in 16.0.6
- electron (npm): affected from 16.0.0-beta.1; fixed in 16.0.6
- electron (npm): affected from 17.0.0-alpha.1; fixed in 17.0.0-alpha.6
- electron (npm): affected from 17.0.0-alpha.1; fixed in 17.0.0-alpha.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21718/ (Markdown: https://insights.sbomify.com/CVE-2022-21718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21718
- OSV: https://osv.dev/vulnerability/CVE-2022-21718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21718/
Summaries are generated and may contain mistakes; the official description above is the record.
