{"answers":{"affected":"2 open source packages ship an affected version, including next. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21721 in the wild and no public exploit code.","fix":"Upgrade next to 12.0.9 or later.","what":"CVE-2022-21721 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21721 and fix it if it is affected.\n\nWhat it is: CVE-2022-21721 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21721 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next (npm): affected from 12.0.0; fixed in 12.0.9\n- next (npm): affected from 12.0.0; fixed in 12.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21721/ (Markdown: https://insights.sbomify.com/CVE-2022-21721/index.md)","id":"CVE-2022-21721","markdown":"https://insights.sbomify.com/CVE-2022-21721/index.md","name":"CVE-2022-21721","record":{"aliases":["GHSA-wr66-vrwm-5g5x"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Next.js framework","requires_auth":"none","summary":"Attackers can cause denial of service in Next.js applications using built-in i18n support via custom servers, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next.js","vendor":"vercel"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Next.js is a React framework. Starting with version 12.0.0 and prior to version 12.0.9, vulnerable code could allow a bad actor to trigger a denial of service attack for anyone using i18n functionality. In order to be affected by this CVE, one must use next start or a custom server and the built-in i18n support. Deployments on Vercel, along with similar environments where invalid requests are filtered before reaching Next.js, are not affected. A patch has been released, `next@12.0.9`, that mitigates this issue. As a workaround, one may ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until it becomes feasible to upgrade.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DOS Vulnerability in next.js","id":"CVE-2022-21721","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"vercel:next.js","products":["vercel:next.js"],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Potential out-of-bound read during RTP/RTCP parsing in PJSIP","id":"CVE-2022-21722"},"packages":[{"ecosystem":"npm","fixed":["12.0.9"],"introduced":["12.0.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-wr66-vrwm-5g5x"},{"ecosystem":"npm","fixed":["12.0.9"],"introduced":["12.0.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-wr66-vrwm-5g5x"}],"prev":{"headline":"SQL injection using custom CSS administration form in GLPI","id":"CVE-2022-21720"},"products":["n/a"],"published":"2022-01-28","related":[{"cvss_score":9.1,"headline":"Authorization Bypass in Next.js Middleware","id":"CVE-2025-29927","kev_date_added":null,"published":"2025-03-21"},{"cvss_score":8.6,"headline":"Next.js: Server-side request forgery in applications using WebSocket upgrades","id":"CVE-2026-44578","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Image Optimization","id":"CVE-2026-94483","kev_date_added":null,"published":"2026-10-02"},{"cvss_score":8.3,"headline":"Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale","id":"CVE-2026-64642","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname","id":"CVE-2026-64645","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Server Actions on Custom Servers","id":"CVE-2026-64649","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.2,"headline":"Next.js: Denial of Service in App Router using Server Actions","id":"CVE-2026-64641","kev_date_added":null,"published":"2026-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-05","vendors":["n/a"]},"summary":"Attackers can cause denial of service in Next.js applications using built-in i18n support via custom servers, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-21721/"}