{"answers":{"affected":"3 open source packages ship an affected version, including joblib. It affects 3 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21797 exists.","fix":"Upgrade joblib to 1.2.0 or later.","what":"CVE-2022-21797 is a high-severity code injection vulnerability in Debian Debian Linux, published on 26 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21797 and fix it if it is affected.\n\nWhat it is: CVE-2022-21797 is a high-severity code injection vulnerability in Debian Debian Linux, published on 26 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21797 exists.\n\nAffected packages and fixed versions:\n- joblib (PyPI): affected all versions; fixed in 1.2.0\n- joblib (PyPI): affected all versions; fixed in 1.2.0\n- joblib (PyPI): affected all versions; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21797/ (Markdown: https://insights.sbomify.com/CVE-2022-21797/index.md)","id":"CVE-2022-21797","markdown":"https://insights.sbomify.com/CVE-2022-21797/index.md","name":"CVE-2022-21797","record":{"aliases":["DEBIAN-CVE-2022-21797","DLA-3193-2","GHSA-6hrg-qmvc-2xh8","MGASA-2022-0375","MINI-jhmp-9jf2-v4gr","OESA-2022-1990","PYSEC-2022-288","UBUNTU-CVE-2022-21797","openSUSE-SU-2022:10214-1","openSUSE-SU-2024:12401-1","openSUSE-SU-2025:14914-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python joblib library","requires_auth":"none","summary":"Attackers can execute arbitrary code via the pre_dispatch flag in the Parallel class due to unsafe eval usage in the joblib library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"joblib","vendor":"joblib_project"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.","ecosystems":["PyPI","SUSE:Package Hub 15 SP3","openSUSE:Leap 15.3","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Arbitrary Code Execution","id":"CVE-2022-21797","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"code_injection","year":"2022"},"n_packages":6,"n_references":9,"next":{"headline":"ICSA-22-053-02 GE Proficy CIMPLICITY-Cleartext","id":"CVE-2022-21798"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"joblib","purl":null,"source":"GHSA-6hrg-qmvc-2xh8"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"joblib","purl":"pkg:pypi/joblib","source":"GHSA-6hrg-qmvc-2xh8"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"joblib","purl":"pkg:pypi/joblib","source":"PYSEC-2022-288"},{"ecosystem":"SUSE:Package Hub 15 SP3","fixed":["0.16.0-bp153.2.3.1"],"introduced":["0"],"last_affected":[],"package":"python-joblib","purl":"pkg:rpm/suse/python-joblib\u0026distro=SUSE%20Package%20Hub%2015%20SP3","source":"openSUSE-SU-2022:10214-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["0.16.0-bp153.2.3.1"],"introduced":["0"],"last_affected":[],"package":"python-joblib","purl":"pkg:rpm/opensuse/python-joblib\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:10214-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.2-2.1"],"introduced":["0"],"last_affected":[],"package":"python-joblib","purl":"pkg:rpm/opensuse/python-joblib\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14914-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2022-21796"},"products":["joblib"],"published":"2022-09-26","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via the pre_dispatch flag in the Parallel class due to unsafe eval usage in the joblib library.","url":"https://insights.sbomify.com/CVE-2022-21797/"}