# CVE-2022-21797: Arbitrary Code Execution

> Attackers can execute arbitrary code via the pre_dispatch flag in the Parallel class due to unsafe eval usage in the joblib library.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2022
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2022-21797, DLA-3193-2, GHSA-6hrg-qmvc-2xh8, MGASA-2022-0375, MINI-jhmp-9jf2-v4gr, OESA-2022-1990, PYSEC-2022-288, UBUNTU-CVE-2022-21797, openSUSE-SU-2022:10214-1, openSUSE-SU-2024:12401-1, openSUSE-SU-2025:14914-1

## What is CVE-2022-21797?

CVE-2022-21797 is a high-severity code injection vulnerability in Debian Debian Linux, published on 26 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-21797?

3 open source packages ship an affected version, including joblib. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joblib` | PyPI | All versions | 1.2.0 |
| `joblib` | PyPI | All versions | 1.2.0 |
| `joblib` | PyPI | All versions | 1.2.0 |
| `python-joblib` | SUSE:Package Hub 15 SP3 | All versions | 0.16.0-bp153.2.3.1 |
| `python-joblib` | openSUSE:Leap 15.3 | All versions | 0.16.0-bp153.2.3.1 |
| `python-joblib` | openSUSE:Tumbleweed | All versions | 1.4.2-2.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Joblib Project Joblib.

## How do I fix CVE-2022-21797?

Upgrade joblib to 1.2.0 or later.

## Is CVE-2022-21797 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21797 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21797 and fix it if it is affected.

What it is: CVE-2022-21797 is a high-severity code injection vulnerability in Debian Debian Linux, published on 26 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21797 exists.

Affected packages and fixed versions:
- joblib (PyPI): affected all versions; fixed in 1.2.0
- joblib (PyPI): affected all versions; fixed in 1.2.0
- joblib (PyPI): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21797/ (Markdown: https://insights.sbomify.com/CVE-2022-21797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21797
- OSV: https://osv.dev/vulnerability/CVE-2022-21797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21797/
Summaries are generated and may contain mistakes; the official description above is the record.
