# CVE-2022-21803: Prototype Pollution

> Prototype pollution in nconf allows attackers to modify Object.prototype, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6xwr-q98w-rvg7

## What is CVE-2022-21803?

CVE-2022-21803 is a high-severity vulnerability in nconf, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package nconf before 0.11.4. When using the memory engine, it is possible to store a nested JSON representation of the configuration. The .set() function, that is responsible for setting the configuration properties, is vulnerable to Prototype Pollution. By providing a crafted property, it is possible to modify the properties on the Object.prototype.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-21803?

2 open source packages ship an affected version, including nconf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nconf` | npm | All versions | 0.11.4 |
| `nconf` | npm | All versions | 0.11.4 |

Products: Nconf Project Nconf.

## How do I fix CVE-2022-21803?

Upgrade nconf to 0.11.4 or later.

## Is CVE-2022-21803 being exploited?

There is no known exploitation of CVE-2022-21803 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21803 and fix it if it is affected.

What it is: CVE-2022-21803 is a high-severity vulnerability in nconf, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21803 in the wild and no public exploit code.

Affected packages and fixed versions:
- nconf (npm): affected all versions; fixed in 0.11.4
- nconf (npm): affected all versions; fixed in 0.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21803/ (Markdown: https://insights.sbomify.com/CVE-2022-21803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21803
- OSV: https://osv.dev/vulnerability/CVE-2022-21803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21803/
Summaries are generated and may contain mistakes; the official description above is the record.
