# CVE-2022-21822: Allocation of Resources Without Limits or Throttling in nvflare

> An unauthenticated attacker can cause resource exhaustion in the NVIDIA FLARE admin interface, leading to system unavailability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jx8f-cpx7-fv47, PYSEC-2026-695

## What is CVE-2022-21822?

CVE-2022-21822 is a high-severity denial of service vulnerability in NVIDIA FLARE, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NVIDIA FLARE contains a vulnerability in the admin interface, where an un-authorized attacker can cause Allocation of Resources Without Limits or Throttling, which may lead to cause system unavailable.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-21822?

3 open source packages ship an affected version, including nvflare. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nvflare` | PyPI | All versions | 2.0.16 |
| `nvflare` | PyPI | All versions | 2.0.16 |
| `nvflare` | PyPI | All versions | 2.0.16 |

Products: Nvidia Federated Learning Application Runtime Environment.

## How do I fix CVE-2022-21822?

Upgrade nvflare to 2.0.16 or later.

## Is CVE-2022-21822 being exploited?

There is no known exploitation of CVE-2022-21822 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21822 and fix it if it is affected.

What it is: CVE-2022-21822 is a high-severity denial of service vulnerability in NVIDIA FLARE, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21822 in the wild and no public exploit code.

Affected packages and fixed versions:
- nvflare (PyPI): affected all versions; fixed in 2.0.16
- nvflare (PyPI): affected all versions; fixed in 2.0.16
- nvflare (PyPI): affected all versions; fixed in 2.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21822/ (Markdown: https://insights.sbomify.com/CVE-2022-21822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21822
- OSV: https://osv.dev/vulnerability/CVE-2022-21822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21822/
Summaries are generated and may contain mistakes; the official description above is the record.
