# CVE-2022-21824: Other in Node

> Prototype pollution in Node.js console.table allows limited assignment of empty strings to object prototype keys via user-controlled input.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2022-21824, AZL-8864, BIT-node-2022-21824, BIT-node-min-2022-21824, CLEANSTART-2026-IE74583, CLEANSTART-2026-JZ00429, CLEANSTART-2026-YV64432, DEBIAN-CVE-2022-21824, GHSA-39wv-qjgj-4jxg

## What is CVE-2022-21824?

CVE-2022-21824 is a high-severity vulnerability in Debian Debian Linux, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Due to the formatting logic of the "console.table()" function it was not safe to allow user controlled input to be passed to the "properties" parameter while simultaneously passing a plain object with at least one property as the first parameter, which could be "__proto__". The prototype pollution has very limited control, in that it only allows an empty string to be assigned to numerical keys of the object prototype.Node.js >= 12.22.9, >= 14.18.3, >= 16.13.2, and >= 17.3.1 use a null protoype for the object these properties are being assigned to.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2022-21824?

2 open source packages ship an affected version, including node and node-min. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 12.0.0 | 12.22.9, 14.18.3, 16.13.2, 17.3.1 |
| `node-min` | Bitnami | From 12.0.0 | 12.22.9, 14.18.3, 16.13.2, 17.3.1 |

Products: Debian Debian Linux, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Nodejs Node.js, Oracle Mysql Cluster, Oracle Mysql Connectors, Oracle Mysql Enterprise Monitor, Oracle Mysql Server, Oracle Mysql Workbench, Oracle Peoplesoft Enterprise Peopletools.

## How do I fix CVE-2022-21824?

Upgrade node to a fixed version for your release line: 12.22.9, 14.18.3, 16.13.2 or 17.3.1.

## Is CVE-2022-21824 being exploited?

There is no known exploitation of CVE-2022-21824 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21824 and fix it if it is affected.

What it is: CVE-2022-21824 is a high-severity vulnerability in Debian Debian Linux, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21824 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 12.0.0; fixed in 12.22.9, 14.18.3, 16.13.2, 17.3.1
- node-min (Bitnami): affected from 12.0.0; fixed in 12.22.9, 14.18.3, 16.13.2, 17.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21824/ (Markdown: https://insights.sbomify.com/CVE-2022-21824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21824
- OSV: https://osv.dev/vulnerability/CVE-2022-21824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21824/
Summaries are generated and may contain mistakes; the official description above is the record.
