CVE-2022-21829 Code injection in concrete CMS
Attackers can achieve remote code execution by exploiting insecure HTTP downloads of zip files in Concrete CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-21829?
CVE-2022-21829 is a critical code injection vulnerability in Concretecms Concrete Cms, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Concrete CMS Versions 9.0.0 through 9.0.2 and 8.5.7 and below can download zip files over HTTP and execute code from those zip files which could lead to an RCE. Fixed by enforcing ‘concrete_secure’ instead of ‘concrete’. Concrete now only makes requests over https even a request comes in via http. Concrete CMS security team ranked this 8 with CVSS v3.1 vector: AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H Credit goes to Anna for reporting HackerOne 1482520.
Weakness: CWE-319
Which versions are affected by CVE-2022-21829?
4 open source packages ship an affected version, including concrete5/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/core Packagist | All versions | 8.5.8 |
concrete5/core Packagist | All versions | 8.5.8 |
concrete5/core Packagist | From 9.0.0 | 9.1.0 |
concrete5/core Packagist | From 9.0.0 | 9.1.0 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2022-21829?
Upgrade concrete5/core to a fixed version for your release line: 8.5.8 or 9.1.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-21829 being exploited?
There is no known exploitation of CVE-2022-21829 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
- CVE-2022-30117 Path traversal in Concrete CMS
Sources
Also known as GHSA-6xc4-7fmm-65q2.