# CVE-2022-21829: Code injection in concrete CMS

> Attackers can achieve remote code execution by exploiting insecure HTTP downloads of zip files in Concrete CMS.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6xc4-7fmm-65q2

## What is CVE-2022-21829?

CVE-2022-21829 is a critical code injection vulnerability in Concretecms Concrete Cms, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Concrete CMS Versions 9.0.0 through 9.0.2 and 8.5.7 and below can download zip files over HTTP and execute code from those zip files which could lead to an RCE. Fixed by enforcing ‘concrete_secure’ instead of ‘concrete’. Concrete now only makes requests over https even a request comes in via http. Concrete CMS security team ranked this 8 with CVSS v3.1 vector: AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H Credit goes to Anna for reporting HackerOne 1482520.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2022-21829?

4 open source packages ship an affected version, including concrete5/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/core` | Packagist | All versions | 8.5.8 |
| `concrete5/core` | Packagist | All versions | 8.5.8 |
| `concrete5/core` | Packagist | From 9.0.0 | 9.1.0 |
| `concrete5/core` | Packagist | From 9.0.0 | 9.1.0 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2022-21829?

Upgrade concrete5/core to a fixed version for your release line: 8.5.8 or 9.1.0.

## Is CVE-2022-21829 being exploited?

There is no known exploitation of CVE-2022-21829 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)
- [CVE-2022-30117](https://insights.sbomify.com/CVE-2022-30117/): Path traversal in Concrete CMS (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21829 and fix it if it is affected.

What it is: CVE-2022-21829 is a critical code injection vulnerability in Concretecms Concrete Cms, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21829 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/core (Packagist): affected all versions; fixed in 8.5.8
- concrete5/core (Packagist): affected all versions; fixed in 8.5.8
- concrete5/core (Packagist): affected from 9.0.0; fixed in 9.1.0
- concrete5/core (Packagist): affected from 9.0.0; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21829/ (Markdown: https://insights.sbomify.com/CVE-2022-21829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21829
- OSV: https://osv.dev/vulnerability/CVE-2022-21829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21829/
Summaries are generated and may contain mistakes; the official description above is the record.
