# CVE-2022-21830: Cross-site Scripting in @rocket.chat/livechat

> An attacker can execute arbitrary scripts in a victim's browser by tricking them into pasting malicious code into the RocketChat LiveChat interface.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hf55-c445-2w97

## What is CVE-2022-21830?

CVE-2022-21830 is a medium-severity cross-site scripting vulnerability in Rocket.chat Livechat, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A blind self XSS vulnerability exists in RocketChat LiveChat <v1.9 that could allow an attacker to trick a victim pasting malicious code in their chat instance.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-21830?

2 open source packages ship an affected version, including @rocket.chat/livechat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@rocket.chat/livechat` | npm | All versions | 1.9.0 |
| `@rocket.chat/livechat` | npm | All versions | 1.9.0 |

Products: Rocket.chat Livechat.

## How do I fix CVE-2022-21830?

Upgrade @rocket.chat/livechat to 1.9.0 or later.

## Is CVE-2022-21830 being exploited?

There is no known exploitation of CVE-2022-21830 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21830 and fix it if it is affected.

What it is: CVE-2022-21830 is a medium-severity cross-site scripting vulnerability in Rocket.chat Livechat, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-21830 in the wild and no public exploit code.

Affected packages and fixed versions:
- @rocket.chat/livechat (npm): affected all versions; fixed in 1.9.0
- @rocket.chat/livechat (npm): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21830/ (Markdown: https://insights.sbomify.com/CVE-2022-21830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21830
- OSV: https://osv.dev/vulnerability/CVE-2022-21830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21830/
Summaries are generated and may contain mistakes; the official description above is the record.
