# CVE-2022-21831: Possible code injection vulnerability in Rails / Active Storage

> Attackers can execute arbitrary code via image processing arguments in Active Storage, requiring an upgrade to secure Ruby on Rails applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-21831, GHSA-w749-p3v6-hccq, UBUNTU-CVE-2022-21831, openSUSE-SU-2024:11903-1, openSUSE-SU-2024:12880-1, openSUSE-SU-2024:14070-1, openSUSE-SU-2025:15113-1

## What is CVE-2022-21831?

CVE-2022-21831 is a critical code injection vulnerability in Debian Debian Linux, published on 26 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-21831?

8 open source packages ship an affected version, including activestorage. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activestorage` | RubyGems | From 5.2.0 | 5.2.6.3 |
| `activestorage` | RubyGems | From 5.2.0 | 5.2.6.3 |
| `activestorage` | RubyGems | From 6.0.0 | 6.0.4.7 |
| `activestorage` | RubyGems | From 6.0.0 | 6.0.4.7 |
| `activestorage` | RubyGems | From 6.1.0 | 6.1.4.7 |
| `activestorage` | RubyGems | From 6.1.0 | 6.1.4.7 |
| `activestorage` | RubyGems | From 7.0.0 | 7.0.2.3 |
| `activestorage` | RubyGems | From 7.0.0 | 7.0.2.3 |
| `ruby3.2-rubygem-activestorage-7.0` | openSUSE:Tumbleweed | All versions | 7.0.4.3-1.1 |
| `rubygem-activestorage-7.0` | openSUSE:Tumbleweed | All versions | 7.0.2.3-1.1 |
| `rubygem-activestorage-7.0` | openSUSE:Tumbleweed | All versions | 7.0.8.4-1.1 |
| `rubygem-activestorage-7.0` | openSUSE:Tumbleweed | All versions | 7.0.8.6-1.3 |

Products: Debian Debian Linux, Rubyonrails Active Storage.

## How do I fix CVE-2022-21831?

Upgrade activestorage to a fixed version for your release line: 5.2.6.3, 6.0.4.7, 6.1.4.7 or 7.0.2.3.

## Is CVE-2022-21831 being exploited?

There is no known exploitation of CVE-2022-21831 in the wild and no public exploit code.

Public exploit code:

- Known security vulnerabilities detected. CVE-2022-21831 Critical severity CVE-2025-24293 Critical severity CVE-2020-8162 High severity CVE-2024-26144 Moderate severity (github_poc): https://github.com/usutani/study-turbolinks-link

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21831 and fix it if it is affected.

What it is: CVE-2022-21831 is a critical code injection vulnerability in Debian Debian Linux, published on 26 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21831 in the wild and no public exploit code.

Affected packages and fixed versions:
- activestorage (RubyGems): affected from 5.2.0; fixed in 5.2.6.3
- activestorage (RubyGems): affected from 5.2.0; fixed in 5.2.6.3
- activestorage (RubyGems): affected from 6.0.0; fixed in 6.0.4.7
- activestorage (RubyGems): affected from 6.0.0; fixed in 6.0.4.7
- activestorage (RubyGems): affected from 6.1.0; fixed in 6.1.4.7
- activestorage (RubyGems): affected from 6.1.0; fixed in 6.1.4.7
- activestorage (RubyGems): affected from 7.0.0; fixed in 7.0.2.3
- activestorage (RubyGems): affected from 7.0.0; fixed in 7.0.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21831/ (Markdown: https://insights.sbomify.com/CVE-2022-21831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21831
- OSV: https://osv.dev/vulnerability/CVE-2022-21831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21831/
Summaries are generated and may contain mistakes; the official description above is the record.
