CVE-2022-2185 Command injection in GitLab

Critical 9.9 Published Updated

An authenticated user with import permissions can achieve remote code execution by importing a maliciously crafted project in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2185?

CVE-2022-2185 is a critical command injection vulnerability in Gitlab Gitlab, published on 1 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A critical issue has been discovered in GitLab affecting all versions starting from 14.0 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 where an authenticated user authorized to import projects could import a maliciously crafted project leading to remote code execution.

Weakness: CWE-78

Which versions are affected by CVE-2022-2185?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.0.014.10.5, 15.0.4, 15.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2185?

Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2022-2185 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2185 exists.

Public exploit code: 1 Nuclei template and 2 proofs of concept on GitHub.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2185, GHSA-rqgw-47f7-cww6.

Is CVE-2022-2185 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free