{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21944 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-21944 is a high-severity path traversal vulnerability in openSUSE Factory, published on 26 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21944 and fix it if it is affected.\n\nWhat it is: CVE-2022-21944 is a high-severity path traversal vulnerability in openSUSE Factory, published on 26 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21944 in the wild and no public exploit code.\n\nAffected product: openSUSE Factory. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21944/ (Markdown: https://insights.sbomify.com/CVE-2022-21944/index.md)","id":"CVE-2022-21944","markdown":"https://insights.sbomify.com/CVE-2022-21944/index.md","name":"CVE-2022-21944","record":{"aliases":["GHSA-rg42-3854-x575","openSUSE-SU-2022:0016-1","openSUSE-SU-2024:11728-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"openSUSE watchman package","requires_auth":"low_privilege","summary":"Local attackers can escalate to root via symlink attack in watchman systemd unit; openSUSE users should upgrade.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"factory_watchman","vendor":"opensuse"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"A UNIX Symbolic Link (Symlink) Following vulnerability in the systemd service file for watchman of openSUSE Backports SLE-15-SP3, Factory allows local attackers to escalate to root. This issue affects: openSUSE Backports SLE-15-SP3 watchman versions prior to 4.9.0. openSUSE Factory watchman versions prior to 4.9.0-9.1.","ecosystems":["SUSE:Package Hub 15 SP3","openSUSE:Leap 15.3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"watchman: chown in watchman@.socket unit allows symlink attack","id":"CVE-2022-21944","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"cscreen: usage of fixed path /tmp/cscreen.debug","id":"CVE-2022-21945"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP3","fixed":["4.9.0-bp153.2.3.1"],"introduced":["0"],"last_affected":[],"package":"watchman","purl":"pkg:rpm/suse/watchman\u0026distro=SUSE%20Package%20Hub%2015%20SP3","source":"openSUSE-SU-2022:0016-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["4.9.0-bp153.2.3.1"],"introduced":["0"],"last_affected":[],"package":"watchman","purl":"pkg:rpm/opensuse/watchman\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:0016-1"}],"prev":{"headline":"iSTAR Ultra","id":"CVE-2022-21941"},"products":["Factory","openSUSE Backports SLE-15-SP3"],"published":"2022-01-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["openSUSE"]},"summary":"Local attackers can escalate to root via symlink attack in watchman systemd unit; openSUSE users should upgrade.","url":"https://insights.sbomify.com/CVE-2022-21944/"}