{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21950 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2022-21950 is a medium-severity missing authorization vulnerability in openSUSE Backports SLE-15-SP3, published on 7 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21950 and fix it if it is affected.\n\nWhat it is: CVE-2022-21950 is a medium-severity missing authorization vulnerability in openSUSE Backports SLE-15-SP3, published on 7 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21950 in the wild and no public exploit code.\n\nAffected product: openSUSE Backports SLE-15-SP3. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21950/ (Markdown: https://insights.sbomify.com/CVE-2022-21950/index.md)","id":"CVE-2022-21950","markdown":"https://insights.sbomify.com/CVE-2022-21950/index.md","name":"CVE-2022-21950","record":{"aliases":["GHSA-3485-7x7c-qrw2","MGASA-2022-0306","openSUSE-SU-2022:10090-1","openSUSE-SU-2022:10091-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"openSUSE canna package","requires_auth":"low_privilege","summary":"Local attackers can hijack the UNIX domain socket due to improper access control on the /tmp/.iroha_unix directory in the canna service.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"canna","vendor":"opensuse"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"A Improper Access Control vulnerability in the systemd service of cana in openSUSE Backports SLE-15-SP3, openSUSE Backports SLE-15-SP4 allows local users to hijack the UNIX domain socket This issue affects: openSUSE Backports SLE-15-SP3 canna versions prior to canna-3.7p3-bp153.2.3.1. openSUSE Backports SLE-15-SP4 canna versions prior to 3.7p3-bp154.3.3.1. openSUSE Factory was also affected. Instead of fixing the package it was deleted there.","ecosystems":["SUSE:Package Hub 15 SP3","SUSE:Package Hub 15 SP4","openSUSE:Leap 15.3","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"canna: unsafe handling of /tmp/.iroha_unix directory","id":"CVE-2022-21950","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"Rancher: Weave CNI password is not set if RKE template is used with CNI value overridden","id":"CVE-2022-21951"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP3","fixed":["3.7p3-bp153.2.3.1"],"introduced":["0"],"last_affected":[],"package":"canna","purl":"pkg:rpm/suse/canna\u0026distro=SUSE%20Package%20Hub%2015%20SP3","source":"openSUSE-SU-2022:10090-1"},{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["3.7p3-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"canna","purl":"pkg:rpm/suse/canna\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2022:10091-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["3.7p3-bp153.2.3.1"],"introduced":["0"],"last_affected":[],"package":"canna","purl":"pkg:rpm/opensuse/canna\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:10090-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.7p3-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"canna","purl":"pkg:rpm/opensuse/canna\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2022:10091-1"}],"prev":{"headline":"Multiple XXE vulnerabilities in OBS","id":"CVE-2022-21949"},"products":["openSUSE Backports SLE-15-SP3","openSUSE Backports SLE-15-SP4"],"published":"2022-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["openSUSE"]},"summary":"Local attackers can hijack the UNIX domain socket due to improper access control on the /tmp/.iroha_unix directory in the canna service.","url":"https://insights.sbomify.com/CVE-2022-21950/"}