CVE-2022-21951 Rancher: Weave CNI password is not set if RKE template is used with CNI value overridden

Medium 6.8 Published Updated

Attackers can intercept and modify network traffic in Rancher clusters created with specific RKE template overrides due to missing encryption.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-21951?

CVE-2022-21951 is a medium-severity vulnerability in SUSE Rancher, published on 25 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Cleartext Transmission of Sensitive Information vulnerability in SUSE Rancher, Rancher allows attackers on the network to read and change network data due to missing encryption of data transmitted via the network when a cluster is created from an RKE template with the CNI value overridden This issue affects: SUSE Rancher Rancher versions prior to 2.5.14; Rancher versions prior to 2.6.5.

Weakness: CWE-319

Which versions are affected by CVE-2022-21951?

4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.

PackageAffectedFixed in
github.com/rancher/rancher GoFrom 2.5.02.5.14
github.com/rancher/rancher GoFrom 2.5.02.5.14
github.com/rancher/rancher GoFrom 2.6.02.6.5
github.com/rancher/rancher GoFrom 2.6.02.6.5

Products include Suse Rancher.

How do I fix CVE-2022-21951?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.14 or 2.6.5.

Is CVE-2022-21951 being exploited?

There is no known exploitation of CVE-2022-21951 in the wild and no public exploit code.

Sources

Also known as GHSA-vrph-m5jj-c46c.

Is CVE-2022-21951 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free