# CVE-2022-21951: Rancher: Weave CNI password is not set if RKE template is used with CNI value overridden

> Attackers can intercept and modify network traffic in Rancher clusters created with specific RKE template overrides due to missing encryption.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vrph-m5jj-c46c

## What is CVE-2022-21951?

CVE-2022-21951 is a medium-severity vulnerability in SUSE Rancher, published on 25 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Cleartext Transmission of Sensitive Information vulnerability in SUSE Rancher, Rancher allows attackers on the network to read and change network data due to missing encryption of data transmitted via the network when a cluster is created from an RKE template with the CNI value overridden This issue affects: SUSE Rancher Rancher versions prior to 2.5.14; Rancher versions prior to 2.6.5.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2022-21951?

4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.14 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.14 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.5 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.5 |

Products: Suse Rancher.

## How do I fix CVE-2022-21951?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.14 or 2.6.5.

## Is CVE-2022-21951 being exploited?

There is no known exploitation of CVE-2022-21951 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21951 and fix it if it is affected.

What it is: CVE-2022-21951 is a medium-severity vulnerability in SUSE Rancher, published on 25 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21951 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.14
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.14
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.5
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21951/ (Markdown: https://insights.sbomify.com/CVE-2022-21951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21951
- OSV: https://osv.dev/vulnerability/CVE-2022-21951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21951/
Summaries are generated and may contain mistakes; the official description above is the record.
