{"answers":{"affected":"2 open source packages ship an affected version, including bottelet/flarepoint. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-22110 in the wild and no public exploit code.","fix":"Upgrade bottelet/flarepoint to 2.2.1 or later.","what":"CVE-2022-22110 is a high-severity vulnerability in Bottelet DaybydayCRM, published on 5 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-22110 and fix it if it is affected.\n\nWhat it is: CVE-2022-22110 is a high-severity vulnerability in Bottelet DaybydayCRM, published on 5 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-22110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bottelet/flarepoint (Packagist): affected from 1.1; fixed in 2.2.1\n- bottelet/flarepoint (Packagist): affected from 1.1; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-22110/ (Markdown: https://insights.sbomify.com/CVE-2022-22110/index.md)","id":"CVE-2022-22110","markdown":"https://insights.sbomify.com/CVE-2022-22110/index.md","name":"CVE-2022-22110","record":{"aliases":["GHSA-96v6-hrwg-p378"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DayByDay CRM","requires_auth":"none","summary":"Weak password requirements in DayByDay CRM allow attackers to easily brute-force user accounts due to insufficient complexity enforcement.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"daybyday_crm","vendor":"daybydaycrm"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-521","name":"Weak Password Requirements"}],"description":"In Daybyday CRM, versions 1.1 through 2.2.0 enforce weak password requirements in the user update functionality. A user with privileges to update his password could change it to a weak password, such as those with a length of a single character. This may allow an attacker to brute-force users’ passwords with minimal to no computational effort.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DayByDay CRM - Weak Password Requirements in Update User","id":"CVE-2022-22110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"DayByDay CRM - Missing Authorization when Changing Password","id":"CVE-2022-22111"},"packages":[{"ecosystem":"Packagist","fixed":["2.2.1"],"introduced":["1.1"],"last_affected":[],"package":"bottelet/flarepoint","purl":null,"source":"GHSA-96v6-hrwg-p378"},{"ecosystem":"Packagist","fixed":["2.2.1"],"introduced":["1.1"],"last_affected":[],"package":"bottelet/flarepoint","purl":"pkg:composer/bottelet/flarepoint","source":"GHSA-96v6-hrwg-p378"}],"prev":{"headline":"DayByDay CRM - Stored Cross-Site Scripting (XSS) in Task Title","id":"CVE-2022-22109"},"products":["DaybydayCRM","flarepoint"],"published":"2022-01-05","related":[{"cvss_score":8.8,"headline":"DayByDay CRM - Missing Authorization when Changing Password","id":"CVE-2022-22111","kev_date_added":null,"published":"2022-01-05"},{"cvss_score":5.4,"headline":"DayByDay CRM - Stored Cross-Site Scripting (XSS) in Task Title","id":"CVE-2022-22109","kev_date_added":null,"published":"2022-01-05"},{"cvss_score":4.3,"headline":"DayByDay CRM - Missing Authorization when Viewing Appointments","id":"CVE-2022-22107","kev_date_added":null,"published":"2022-01-05"},{"cvss_score":4.3,"headline":"DayByDay CRM - Missing Authorization when Viewing Absences","id":"CVE-2022-22108","kev_date_added":null,"published":"2022-01-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Bottelet"]},"summary":"Weak password requirements in DayByDay CRM allow attackers to easily brute-force user accounts due to insufficient complexity enforcement.","url":"https://insights.sbomify.com/CVE-2022-22110/"}