# CVE-2022-22110: DayByDay CRM - Weak Password Requirements in Update User

> Weak password requirements in DayByDay CRM allow attackers to easily brute-force user accounts due to insufficient complexity enforcement.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-96v6-hrwg-p378

## What is CVE-2022-22110?

CVE-2022-22110 is a high-severity vulnerability in Bottelet DaybydayCRM, published on 5 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Daybyday CRM, versions 1.1 through 2.2.0 enforce weak password requirements in the user update functionality. A user with privileges to update his password could change it to a weak password, such as those with a length of a single character. This may allow an attacker to brute-force users’ passwords with minimal to no computational effort.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2022-22110?

2 open source packages ship an affected version, including bottelet/flarepoint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bottelet/flarepoint` | Packagist | From 1.1 | 2.2.1 |
| `bottelet/flarepoint` | Packagist | From 1.1 | 2.2.1 |

Products: Daybydaycrm Daybyday Crm.

## How do I fix CVE-2022-22110?

Upgrade bottelet/flarepoint to 2.2.1 or later.

## Is CVE-2022-22110 being exploited?

There is no known exploitation of CVE-2022-22110 in the wild and no public exploit code.

## Other vulnerabilities in Bottelet DaybydayCRM

- [CVE-2022-22111](https://insights.sbomify.com/CVE-2022-22111/): DayByDay CRM - Missing Authorization when Changing Password (high 8.8)
- [CVE-2022-22109](https://insights.sbomify.com/CVE-2022-22109/): DayByDay CRM - Stored Cross-Site Scripting (XSS) in Task Title (medium 5.4)
- [CVE-2022-22107](https://insights.sbomify.com/CVE-2022-22107/): DayByDay CRM - Missing Authorization when Viewing Appointments (medium 4.3)
- [CVE-2022-22108](https://insights.sbomify.com/CVE-2022-22108/): DayByDay CRM - Missing Authorization when Viewing Absences (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22110 and fix it if it is affected.

What it is: CVE-2022-22110 is a high-severity vulnerability in Bottelet DaybydayCRM, published on 5 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22110 in the wild and no public exploit code.

Affected packages and fixed versions:
- bottelet/flarepoint (Packagist): affected from 1.1; fixed in 2.2.1
- bottelet/flarepoint (Packagist): affected from 1.1; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22110/ (Markdown: https://insights.sbomify.com/CVE-2022-22110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22110
- OSV: https://osv.dev/vulnerability/CVE-2022-22110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22110/
Summaries are generated and may contain mistakes; the official description above is the record.
