CVE-2022-2227 Missing authorization in GitLab

Low 3.1 Published Updated

A former project maintainer can improperly access job and project metadata via the runner jobs API due to insufficient access controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2227?

CVE-2022-2227 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper access control in the runner jobs API in GitLab CE/EE affecting all versions prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows a previous maintainer of a project with a specific runner to access job and project meta data under certain conditions

Weakness: CWE-732

Which versions are affected by CVE-2022-2227?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions14.10.5, 15.0.4, 15.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2227?

Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-2227 being exploited?

There is no known exploitation of CVE-2022-2227 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2227, GHSA-294h-9fqc-xfq7, UBUNTU-CVE-2022-2227.

Is CVE-2022-2227 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free