CVE-2022-2229 Information disclosure in GitLab
Attackers can extract values of unprotected CI/CD variables in public or accessible private projects, potentially exposing sensitive configuration data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2229?
CVE-2022-2229 is a high-severity vulnerability in Gitlab Gitlab, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An improper authorization issue in GitLab CE/EE affecting all versions from 13.7 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows an attacker to extract the value of an unprotected variable they know the name of in public projects or private projects they're a member of.
Which versions are affected by CVE-2022-2229?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.7.0 | 14.10.5, 15.0.4, 15.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2229?
Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.
Is CVE-2022-2229 being exploited?
There is no known exploitation of CVE-2022-2229 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2229, GHSA-c63c-249m-g37m, UBUNTU-CVE-2022-2229.