# CVE-2022-22293: Cross site scripting in dolibarr

> An attacker can inject malicious HTML into the Dolibarr admin interface via the MAIN_MAX_DECIMALS_TOT parameter, potentially leading to session hijacking or data theft.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-dolibarr-2022-22293, GHSA-g5jm-xhwm-9xp9, UBUNTU-CVE-2022-22293

## What is CVE-2022-22293?

CVE-2022-22293 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 1 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

admin/limits.php in Dolibarr 7.0.2 allows HTML injection, as demonstrated by the MAIN_MAX_DECIMALS_TOT parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-22293?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 13.0.0 |
| `dolibarr/dolibarr` | Packagist | All versions | 13.0.0 |
| `dolibarr` | Bitnami | From 7.0.2 to 7.0.2 | None |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2022-22293?

Upgrade dolibarr/dolibarr to 13.0.0 or later.

## Is CVE-2022-22293 being exploited?

There is no known exploitation of CVE-2022-22293 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22293 and fix it if it is affected.

What it is: CVE-2022-22293 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 1 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-22293 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 13.0.0
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 13.0.0
- dolibarr (Bitnami): affected from 7.0.2 up to 7.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22293/ (Markdown: https://insights.sbomify.com/CVE-2022-22293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22293
- OSV: https://osv.dev/vulnerability/CVE-2022-22293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22293/
Summaries are generated and may contain mistakes; the official description above is the record.
